crash on start with trunk builds [@ nsCaret::Init]

VERIFIED DUPLICATE of bug 254967

Status

()

Firefox
General
--
blocker
VERIFIED DUPLICATE of bug 254967
14 years ago
7 years ago

People

(Reporter: gandalf, Assigned: Blake Ross)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040807 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040807 Firefox/0.9.1+

Firefox 20040811 trunk crashes on launch.
AthlonXP 1.8, GCC 3.3.4, Kernel 2.6.7, Slackware 10

Reproducible: Always
Steps to Reproduce:
1. Download nightly
2. unpack
3. launch

Actual Results:  
crash

Expected Results:  
Launch

TB538240K
TB538238X
TB538235K
(Reporter)

Comment 1

14 years ago
no problem with branch 0.9 build
*** Bug 255282 has been marked as a duplicate of this bug. ***
Talkback stack is:

nsCaret::Init() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/layout/base/src/nsCaret.cpp,
line 710]
PresShell::Init() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 710]
nsDocument::doCreateShell() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsDocument.cpp,
line 1300]
nsHTMLDocument::CreateShell() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/content/html/document/src/nsHTMLDocument.cpp,
line 417]
DocumentViewerImpl::InitPresentationStuff() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsDocumentViewer.cpp,
line 637]
DocumentViewerImpl::InitInternal() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsDocumentViewer.cpp,
line 857]
DocumentViewerImpl::Init() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsDocumentViewer.cpp,
line 624]
nsDocShell::SetupNewViewer() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/docshell/base/nsDocShell.cpp,
line 710]
nsDocShell::Embed() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/docshell/base/nsDocShell.cpp,
line 692]
nsDocShell::CreateAboutBlankContentViewer() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/docshell/base/nsDocShell.cpp,
line 704]
nsDocShell::EnsureContentViewer() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/docshell/base/nsDocShell.cpp,
line 4453]
nsDocShell::GetInterface() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/docshell/base/nsDocShell.cpp,
line 704]
nsGetInterface::operator() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/glue/nsIInterfaceRequestorUtils.cpp,
line 710]
nsCOMPtr_base::assign_from_helper() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/glue/nsCOMPtr.cpp,
line 114]
GlobalWindowImpl::GetDocument() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 1392]
nsWindowWatcher::URIfromURL() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp,
line 704]
nsWindowWatcher::OpenWindowJS() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp,
line 498]
nsWindowWatcher::OpenWindow() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp,
line 457]
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode)() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2027]
XPC_WN_CallMethod() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1287]
js_Invoke() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsinterp.c,
line 1281]
js_Interpret() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsinterp.c,
line 3376]
js_Invoke() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsinterp.c,
line 1301]
nsXPCWrappedJSClass::CallMethod() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp,
line 1336]
nsXPCWrappedJS::CallMethod() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp,
line 450]
PrepareAndDispatch() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_gcc_x86_unix.cpp,
line 100]
xre_main() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/toolkit/xre/nsAppRunner.cpp,
line 1981]
main() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/browser/app/nsBrowserApp.cpp,
line 59]
libc.so.6 + 0x15936 (0x4096d936)
Severity: critical → blocker
Summary: crash on start with trunk builds → crash on start with trunk builds [@ nsCaret::Init]

Updated

14 years ago
Keywords: crash
(Reporter)

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 254967 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsCaret::Init]
You need to log in before you can comment on or make changes to this bug.