customize sidebar "hangs" the app

VERIFIED WORKSFORME

Status

P1
normal
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: sspitzer, Assigned: slamm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

when I click on the customize sidebar, the app never comes back, or repaints.

info threads
  7 Thread 20879  0x40368861 in __libc_nanosleep ()
  4 Thread 20867  0x402f81bb in __sigsuspend (set=0xbf5ffba4) at
../sysdeps/unix/sysv/linux/sigsuspend.c:48
  3 Thread 20866  0x403817d0 in __poll (fds=0xbf7ffc88, nfds=2, timeout=35000)
at ../sysdeps/unix/sysv/linux/poll.c:45
* 2 Thread 20856  0x4124fcf9 in nsTableFrame::GetTableFrame
(aSourceFrame=0x8b24488, aTableFrame=@0x8a85858) at nsTableFrame.cpp:4049
  1 Thread 20865  0x403817d0 in __poll (fds=0x80d1798, nfds=1, timeout=2000) at
../sysdeps/unix/sysv/linux/poll.c:45

thread 3 is here:

#0  0x4124fcf9 in nsTableFrame::GetTableFrame (aSourceFrame=0x8b24488,
aTableFrame=@0x8a85858) at nsTableFrame.cpp:4049
#1  0x4108bdc5 in nsContainerFrame::ReflowChild (this=0x8b2434c,
aKidFrame=0x8b24488, aPresContext=0x8a85858, aDesiredSize=@0xbfffad80,
aReflowState=@0xbfffacb8, aX=0, aY=0, aFlags=0, aStatus=@0xbfffb48c) at
nsContainerFrame.cpp:637
#2  0x4124d638 in nsTableFrame::ReflowMappedChildren (this=0x8b2434c,
aPresContext=0x8a85858, aDesiredSize=@0xbfffb218, aReflowState=@0xbfffae14,
aStatus=@0xbfffb48c) at nsTableFrame.cpp:2995
#3  0x4124b09c in nsTableFrame::ResizeReflowPass2 (this=0x8b2434c,
aPresContext=0x8a85858, aDesiredSize=@0xbfffb218, aReflowState=@0xbfffaf00,
aStatus=@0xbfffb48c) at nsTableFrame.cpp:1987
#4  0x4124a579 in nsTableFrame::Reflow (this=0x8b2434c, aPresContext=0x8a85858,
aDesiredSize=@0xbfffb218, aReflowState=@0xbfffb178, aStatus=@0xbfffb48c) at
nsTableFrame.cpp:1655
#5  0x41286965 in nsTreeFrame::Reflow (this=0x8b2434c, aPresContext=0x8a85858,
aDesiredSize=@0xbfffb218, aReflowState=@0xbfffb178, aStatus=@0xbfffb48c) at
nsTreeFrame.cpp:397
#6  0x4108bdc5 in nsContainerFrame::ReflowChild (this=0x8b242ec,
aKidFrame=0x8b2434c, aPresContext=0x8a85858, aDesiredSize=@0xbfffb218,
aReflowState=@0xbfffb178, aX=0, aY=0, aFlags=0, aStatus=@0xbfffb48c) at
nsContainerFrame.cpp:637
#7  0x41253b5a in nsTableOuterFrame::Reflow (this=0x8b242ec,
aPresContext=0x8a85858, aDesiredSize=@0xbfffb58c, aReflowState=@0xbfffb338,
aStatus=@0xbfffb48c) at nsTableOuterFrame.cpp:1009
#8  0x41284a0f in nsTreeOuterFrame::Reflow (this=0x8b242ec,
aPresContext=0x8a85858, aDesiredSize=@0xbfffb58c, aReflowState=@0xbfffb338,
aStatus=@0xbfffb48c) at nsTreeOuterFrame.cpp:132
#9  0x41087a87 in nsBlockReflowContext::ReflowBlock (this=0xbfffb54c,
aFrame=0x8b242ec, aSpace=@0xbfffb494, aApplyTopMargin=0, aPrevBottomMargin=0,
aIsAdjacentWithTop=1, aComputedOffsets=@0xbfffb4a4,
aFrameReflowStatus=@0xbfffb48c) at nsBlockReflowContext.cpp:425
#10 0x41080a7c in nsBlockFrame::ReflowBlockFrame (this=0x8b242a4,
aState=@0xbfffb90c, aLine=0x8b26710, aKeepReflowGoing=0xbfffb6ec) at
nsBlockFrame.cpp:3426
#11 0x4107f4de in nsBlockFrame::ReflowLine (this=0x8b242a4, aState=@0xbfffb90c,
aLine=0x8b26710, aKeepReflowGoing=0xbfffb6ec, aDamageDirtyArea=0) at
nsBlockFrame.cpp:2746
#12 0x4107ee01 in nsBlockFrame::ReflowDirtyLines (this=0x8b242a4,
aState=@0xbfffb90c) at nsBlockFrame.cpp:2557
#13 0x4107cfd0 in nsBlockFrame::Reflow (this=0x8b242a4, aPresContext=0x8a85858,
aMetrics=@0xbfffcad8, aReflowState=@0xbfffbb20, aStatus=@0xbfffcd78) at
nsBlockFrame.cpp:1532
#14 0x41276aa4 in nsBoxFrame::FlowChildAt (this=0x8b24264, childFrame=0x8b242a4,
aPresContext=0x8a85858, desiredSize=@0xbfffcad8, aReflowState=@0xbfffbecc,
aStatus=@0xbfffcd78, aInfo=@0x8b28be0, aRedraw=@0xbfffbdcc, aReason=@0xbfffbd28)
at nsBoxFrame.cpp:1147
#15 0x41275da1 in nsBoxFrame::FlowChildren (this=0x8b24264,
aPresContext=0x8a85858, aDesiredSize=@0xbfffcad8, aReflowState=@0xbfffbecc,
aStatus=@0xbfffcd78, rect=@0xbfffbe78) at nsBoxFrame.cpp:686
#16 0x41275a1c in nsBoxFrame::Reflow (this=0x8b24264, aPresContext=0x8a85858,
aDesiredSize=@0xbfffcad8, aReflowState=@0xbfffbecc, aStatus=@0xbfffcd78) at
nsBoxFrame.cpp:573
#17 0x41276aa4 in nsBoxFrame::FlowChildAt (this=0x8b241a0, childFrame=0x8b24264,
aPresContext=0x8a85858, desiredSize=@0xbfffcad8, aReflowState=@0xbfffc278,
aStatus=@0xbfffcd78, aInfo=@0x8b29c58, aRedraw=@0xbfffc178, aReason=@0xbfffc0d4)
at nsBoxFrame.cpp:1147
#18 0x41275da1 in nsBoxFrame::FlowChildren (this=0x8b241a0,
aPresContext=0x8a85858, aDesiredSize=@0xbfffcad8, aReflowState=@0xbfffc278,
aStatus=@0xbfffcd78, rect=@0xbfffc224) at nsBoxFrame.cpp:686
#19 0x41275a1c in nsBoxFrame::Reflow (this=0x8b241a0, aPresContext=0x8a85858,
aDesiredSize=@0xbfffcad8, aReflowState=@0xbfffc278, aStatus=@0xbfffcd78) at
nsBoxFrame.cpp:573
#20 0x41276aa4 in nsBoxFrame::FlowChildAt (this=0x8b1d748, childFrame=0x8b241a0,
aPresContext=0x8a85858, desiredSize=@0xbfffcad8, aReflowState=@0xbfffc624,
aStatus=@0xbfffcd78, aInfo=@0x8b29db8, aRedraw=@0xbfffc524, aReason=@0xbfffc480)
at nsBoxFrame.cpp:1147
#21 0x41275da1 in nsBoxFrame::FlowChildren (this=0x8b1d748,
aPresContext=0x8a85858, aDesiredSize=@0xbfffcad8, aReflowState=@0xbfffc624,
aStatus=@0xbfffcd78, rect=@0xbfffc5d0) at nsBoxFrame.cpp:686
#22 0x41275a1c in nsBoxFrame::Reflow (this=0x8b1d748, aPresContext=0x8a85858,
aDesiredSize=@0xbfffcad8, aReflowState=@0xbfffc624, aStatus=@0xbfffcd78) at
nsBoxFrame.cpp:573
#23 0x41276aa4 in nsBoxFrame::FlowChildAt (this=0x8b1d588, childFrame=0x8b1d748,
aPresContext=0x8a85858, desiredSize=@0xbfffcad8, aReflowState=@0xbfffca38,
aStatus=@0xbfffcd78, aInfo=@0x8b2b020, aRedraw=@0xbfffc8d0, aReason=@0xbfffc82c)
at nsBoxFrame.cpp:1147
#24 0x41275da1 in nsBoxFrame::FlowChildren (this=0x8b1d588,
aPresContext=0x8a85858, aDesiredSize=@0xbfffcad8, aReflowState=@0xbfffca38,
aStatus=@0xbfffcd78, rect=@0xbfffc97c) at nsBoxFrame.cpp:686
#25 0x41275a1c in nsBoxFrame::Reflow (this=0x8b1d588, aPresContext=0x8a85858,
aDesiredSize=@0xbfffcad8, aReflowState=@0xbfffca38, aStatus=@0xbfffcd78) at
nsBoxFrame.cpp:573
#26 0x4108bdc5 in nsContainerFrame::ReflowChild (this=0x8b1d54c,
aKidFrame=0x8b1d588, aPresContext=0x8a85858, aDesiredSize=@0xbfffcad8,
aReflowState=@0xbfffca38, aX=0, aY=0, aFlags=0, aStatus=@0xbfffcd78) at
nsContainerFrame.cpp:637
#27 0x410a1c27 in RootFrame::Reflow (this=0x8b1d54c, aPresContext=0x8a85858,
aDesiredSize=@0xbfffcc30, aReflowState=@0xbfffcb88, aStatus=@0xbfffcd78) at
nsHTMLFrame.cpp:326
#28 0x4108bdc5 in nsContainerFrame::ReflowChild (this=0x8b1d510,
aKidFrame=0x8b1d54c, aPresContext=0x8a85858, aDesiredSize=@0xbfffcc30,
aReflowState=@0xbfffcb88, aX=0, aY=0, aFlags=0, aStatus=@0xbfffcd78) at
nsContainerFrame.cpp:637
#29 0x410d4d07 in ViewportFrame::Reflow (this=0x8b1d510, aPresContext=0x8a85858,
aDesiredSize=@0xbfffcdec, aReflowState=@0xbfffccd8, aStatus=@0xbfffcd78) at
nsViewportFrame.cpp:530
#30 0x410a3397 in nsHTMLReflowCommand::Dispatch (this=0x8b4c670,
aPresContext=0x8a85858, aDesiredSize=@0xbfffcdec, aMaxSize=@0xbfffcdcc,
aRendContext=@0x8ab8d98) at nsHTMLReflowCommand.cpp:144
#31 0x410bfcdf in PresShell::ProcessReflowCommands (this=0x8a3ab18,
aInterruptible=0) at nsPresShell.cpp:1943
#32 0x410bc5ce in PresShell::ExitReflowLock (this=0x8a3ab18, aTryToReflow=1) at
nsPresShell.cpp:855
#33 0x410c1910 in PresShell::ContentAppended (this=0x8a3ab18,
aDocument=0x89b3908, aContainer=0x8b11f78, aNewIndexInContainer=2) at
nsPresShell.cpp:2495
#34 0x40ad1c31 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/components/librdf.so
#35 0x40ab5a24 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/components/librdf.so
#36 0x40ada6cb in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/components/librdf.so
#37 0x40ad1947 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/components/librdf.so
#38 0x40aac9d0 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/components/librdf.so
#39 0x40aa7e30 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/components/librdf.so
#40 0x40afe7e1 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/components/librdf.so
#41 0x40492e27 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/libjsdom.so
#42 0x4008ddbe in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/libmozjs.so
#43 0x4009c721 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/libmozjs.so
#44 0x4008de1d in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/libmozjs.so
#45 0x4009c721 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/libmozjs.so
#46 0x4008de1d in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/libmozjs.so
#47 0x4008e15c in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/libmozjs.so
#48 0x400628d7 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/libmozjs.so
#49 0x4045e9d9 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/libjsdom.so
#50 0x4049e0a9 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/libjsdom.so
#51 0x4106b686 in nsEventListenerManager::HandleEventSubType (this=0x8ad42f0,
aListenerStruct=0x8acfdf8, aDOMEvent=0x8b2d544, aSubType=1) at
nsEventListenerManager.cpp:680
#52 0x4106cbca in nsEventListenerManager::HandleEvent (this=0x8ad42f0,
aPresContext=0x8a85858, aEvent=0xbffff428, aDOMEvent=0xbffff068, aFlags=7,
aEventStatus=0xbffff468) at nsEventListenerManager.cpp:1231
#53 0x40478411 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/libjsdom.so
#54 0x40bb9060 in nsWebShell::OnEndDocumentLoad (this=0x8a34890,
loader=0x8a34a70, channel=0x8a29510, aStatus=0) at nsWebShell.cpp:3121
#55 0x40baedc6 in nsDocLoaderImpl::FireOnEndDocumentLoad (this=0x8a34a70,
aLoadInitiator=0x8a34a70, aDocChannel=0x8a29510, aStatus=0) at
nsDocLoader.cpp:833
#56 0x40baea63 in nsDocLoaderImpl::DocLoaderIsEmpty (this=0x8a34a70, aStatus=0)
at nsDocLoader.cpp:723
#57 0x40bae8d8 in nsDocLoaderImpl::OnStopRequest (this=0x8a34a70,
aChannel=0x8b2d838, aCtxt=0x0, aStatus=0, aMsg=0x0) at nsDocLoader.cpp:668
#58 0x406423b2 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/components/libnecko.so
#59 0x40676813 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/components/libnecko_file.so
#60 0x4062e46d in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/components/libnecko.so
#61 0x4062db57 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/components/libnecko.so
#62 0x4017f3fb in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/libxpcom.so
#63 0x4017f30c in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/libxpcom.so
#64 0x40180e0c in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/libxpcom.so
#65 0x406f00c4 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/libwidget_gtk.so
#66 0x406efd4f in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/libwidget_gtk.so
#67 0x408a73ca in ?? () from /usr/lib/libglib-1.2.so.0
#68 0x408a8a86 in ?? () from /usr/lib/libglib-1.2.so.0
#69 0x408a9041 in ?? () from /usr/lib/libglib-1.2.so.0
#70 0x408a91e1 in ?? () from /usr/lib/libglib-1.2.so.0
#71 0x407d27a9 in ?? () from /usr/lib/libgtk-1.2.so.0
#72 0x406f06c7 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/libwidget_gtk.so
#73 0x405a6ecd in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/ns/dist/bin/libnsappshell.so
#74 0x804c1dd in main1 (argc=1, argv=0xbffff944) at nsAppRunner.cpp:597
#75 0x804c667 in main (argc=1, argv=0xbffff944) at nsAppRunner.cpp:690
#76 0x402f1cb3 in __libc_start_main (main=0x804c44c <main>, argc=1,
argv=0xbffff944, init=0x804a588 <_init>, fini=0x8050fd8 <_fini>,
rtld_fini=0x4000a350, stack_end=0xbffff93c) at
../sysdeps/generic/libc-start.c:78

Comment 1

19 years ago
*** Bug 25091 has been marked as a duplicate of this bug. ***

Comment 2

19 years ago
*** Bug 25572 has been marked as a duplicate of this bug. ***

Comment 3

19 years ago
marking M14 and beta1 since the dup was marked as such
Keywords: beta1
Target Milestone: M14

Comment 4

19 years ago
Putting on PDT+ radar for beta1.
Whiteboard: [PDT+]
(Assignee)

Comment 5

19 years ago
This is holding up my other feature work.
Status: NEW → ASSIGNED
Priority: P3 → P1
(Assignee)

Comment 6

19 years ago
This works for me on linux today.

Comment 7

19 years ago
Working for me on windows mozilla build (2000020211m14).
working for me now, too.

marking works for me.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 9

19 years ago
okay on mac also, another miracle fix :-)
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
*** Bug 27521 has been marked as a duplicate of this bug. ***

Comment 11

19 years ago
Not so miraculous.  I fixed it. :)
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.