Closed Bug 255899 Opened 16 years ago Closed 15 years ago

when switching to a tab with long title, the title-text overlaps the tab for a short time

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: norbert.notz, Assigned: bugs)

References

Details

(Keywords: polish, regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.8a3) Gecko/20040816 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.8a3) Gecko/20040816 Firefox/0.9.1+

On my old, slow Windows PC I can reproduce a problem when switching between tabs:

If I switch to a tab which page has a title that is to long for the tab, I can
see for a short moment that the text with the title overlaps the tab. A short
time later the text is correctly cut.

I see this as "minor" bug.

Please have a look at the attached screenshots.

(Please not that I have found this bug with a latest-trunk nightly under Windows
95. But I guess it exists also on other operating systems and Firefox-versions.)

Reproducible: Always
Steps to Reproduce:
Attachment #156354 - Attachment description: screenshot 1 → screenshot 1: Here you can see the bug.
Attachment #156355 - Attachment description: screenshot2 → screenshot2: After a short time, the title is display correctly.
Attachment #156355 - Attachment description: screenshot2: After a short time, the title is display correctly. → screenshot2: After a short time, the title is displayed correctly.
Attachment #156355 - Attachment description: screenshot2: After a short time, the title is displayed correctly. → screenshot 2: After a short time, the title is displayed correctly.
OS: Windows 95 → Windows XP
Confirmed.

I can't see the bug, using:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/2004-08-09
Firefox/0.9.1+
I an see the bug, using:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/2004-08-10
Firefox/0.9.1+

At the moment whe the title overlap happens, the favicons of all the tabs aren't
there anymore. You can see this also with the attached screenshots. 
Severity: minor → normal
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish, regression
*** Bug 259106 has been marked as a duplicate of this bug. ***
I'm pretty sure I've seen this problem before that date, but I do not know
specifically when.
I've backed out the patch for bug 230170 in my debug build and then the bug
seemed to be gone. Then, after I reapplied the patch, the bug seemed to reappear
again.
Depends on: 230170
Blocks: 230170
No longer depends on: 230170
So I'm betting the problem is that something is forcing a repaint before the new
styles have been applied.... That would likely be fixed by bug 238493.
Depends on: 238493
Ok, not sure if this is useful, but only backing out the stuff (and putting the
old stuff back in) in nsCSSFrameConstructor::AttributeChanged of the patch for
bug 230170 seems also not to trigger the bug.
Depends on: 244366
Please retest in a build from today or later?
I actually haven't seen this for a few days, if not a few weeks...
Well, resolve worksforme as appropriate.  ;)
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050120 Firefox/1.0+

Confirming fixed as of today

->resolved/WFM
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
Well, fwiw, I could see it in yesterday's build, but not in today's build.
You need to log in before you can comment on or make changes to this bug.