Pressing delete key on attachment deletes mail instead of attachment

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
critical
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: blitzreiter, Assigned: Scott MacGregor)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7) Gecko/20040626 Firefox/0.9.1

I tried to kill an attachment in an mail in my outbox, I clicked on the mail, I
marked the attachment and then pressed "del", the whole Mail was lost to trash.
Unfortunately I lost the mail a second time.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.



Expected Results:  
ceterum censeo that mails in the outbox shall be automatically switched to an
edit mode when clicked onto. It often happens that you sent a document and while
it is in your outbox you want to update the attachment to a newer version or add
additional information to the mail. For offline mailing this is essential and i
am very unpleased about the way thunderbird handles the outbox (hides the sent
unsent mail option ecc.).
(Reporter)

Updated

12 years ago
Summary: mail loss in outbox → mail loss in outbox due to attachment delete
I can still confirm this with my latest cvs build.

David, this is another bogus focus bug. Although an attachment is focused the whole message gets deleted when pressing Delete. At the time when you had checked-in that new amazing feature the handling of Delete has changed. Now Delete isn't only responsible for deleting a message itself. Now we have more conditions, like the attachment stuff.

When pressing Delete we should first check where the focus is located. Is it within the attachment box then only the selected attachment has to be deleted. Otherwise we can safely delete the message.

Any chance to get this in for 1.5? I believe that a lot of users will be affected by this dataloss issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: dataloss
OS: Windows XP → All
Hardware: PC → All

Comment 2

12 years ago
While I agree that delete when an attachment is selected shouldn't delete the message, it's too late for 1.5, and the message should be in the trash folder in any case.
Sorry, I mixed up the bugs. This one handles an issue within the compose window and not the main window which my one is related. I'll file a new bug.
Summary: mail loss in outbox due to attachment delete → Pressing delete key on attachment deletes mail instead of attachment
By the way, I can't reproduce this issue within the compose window. Reporter, if you can still see it, feel free to reopen.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.