Last Comment Bug 256328 - Page is layed out with horizontal rules through most of page background
: Page is layed out with horizontal rules through most of page background
Status: RESOLVED FIXED
: fixed1.8, pp
Product: Core Graveyard
Classification: Graveyard
Component: GFX: Gtk (show other bugs)
: Trunk
: x86 Linux
: -- major (vote)
: ---
Assigned To: tor
: Hixie (not reading bugmail)
Mentors:
http://www.pbs.org/cringely/pulpit/pu...
: 295127 307782 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-20 12:35 PDT by Joe McCabe
Modified: 2009-01-22 10:17 PST (History)
8 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screen capture of Mozilla displaying page (170.51 KB, image/png)
2004-08-20 12:37 PDT, Joe McCabe
no flags Details
Screen capture of Konqueror displaying page (180.79 KB, image/png)
2004-08-20 12:37 PDT, Joe McCabe
no flags Details
A reduced test case. (1.03 KB, application/x-gzip)
2004-08-20 13:55 PDT, Joe McCabe
no flags Details
The image (881 bytes, image/gif)
2004-09-14 09:13 PDT, Boris Zbarsky [:bz]
no flags Details
Testcase using that image (327 bytes, text/html)
2004-09-14 09:15 PDT, Boris Zbarsky [:bz]
no flags Details
use old tiling method for buggy X servers (6.55 KB, patch)
2004-09-15 10:12 PDT, tor
blizzard: review+
roc: superreview+
asa: approval1.8a4+
Details | Diff | Review
use old tiling method also for 4.3.0.x (792 bytes, patch)
2005-09-13 02:03 PDT, Elmar Ludwig
tor: review+
roc: superreview+
asa: approval1.8b5+
Details | Diff | Review

Description Joe McCabe 2004-08-20 12:35:24 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a3) Gecko/20040819
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a3) Gecko/20040819

The Bob Cringely column uses a lot of CSS. It seems to break when viewed in Mozilla.



Reproducible: Always
Steps to Reproduce:
Comment 1 Joe McCabe 2004-08-20 12:37:16 PDT
Created attachment 156624 [details]
Screen capture of Mozilla displaying page
Comment 2 Joe McCabe 2004-08-20 12:37:41 PDT
Created attachment 156625 [details]
Screen capture of Konqueror displaying page
Comment 3 Bill Mason 2004-08-20 13:11:39 PDT
WFM 20040817 PC/Win2000
Comment 4 Boris Zbarsky [:bz] 2004-08-20 13:19:29 PDT
Minimal testcase needed.
Comment 5 Joe McCabe 2004-08-20 13:55:26 PDT
Created attachment 156633 [details]
A reduced test case.

This tarball contains an HTML file, a CSS file, and the background image that
the CSS file refers to.
Comment 6 Boris Zbarsky [:bz] 2004-09-14 09:13:57 PDT
Created attachment 158880 [details]
The image
Comment 7 Boris Zbarsky [:bz] 2004-09-14 09:15:26 PDT
Created attachment 158881 [details]
Testcase using that image
Comment 8 Boris Zbarsky [:bz] 2004-09-14 09:18:05 PDT
Not an issue on Windows, but I do see this on Linux.  The image has white on the
left and transparent on the right, and the transparent part paints the line garbage.

tor, could you check this out, please?  This looks similar to bug 245377...
Comment 9 tor 2004-09-14 10:12:17 PDT
FWIW, I see this on a fedora core 1 machine (s3 savage) but not on a fedora
core 2 box (i845).  X server bug with tile/stipple with rop, maybe?

Comment 10 Boris Zbarsky [:bz] 2004-09-14 18:48:19 PDT
Possible, but may be worth working around if so...
Comment 11 Joe McCabe 2004-09-14 20:13:16 PDT
I see this on a Red Hat 9 box, but it's had many packages updated over a long
period. It is far from vanilla.
Comment 12 tor 2004-09-14 20:23:33 PDT
This change after XFree86 4.3 looks somewhat suspicious:

 660. Fix a bug in the fbgc.c code that caused the even stipple code path to
      be used instead of the odd stipple path. Basically causing glitches in
      rendering or no rendering at all. (Alan Hourihane).
Comment 13 tor 2004-09-15 10:12:07 PDT
Created attachment 158996 [details] [diff] [review]
use old tiling method for buggy X servers

Built a couple servers with and without the fbgc fixes, and that did
appear to be the problem.  This patch restores the old tiling code
that was deleted in bug 244506 and uses it on XFree86 <= 4.3.
Comment 14 Christopher Blizzard (:blizzard) 2004-09-22 12:03:00 PDT
Comment on attachment 158996 [details] [diff] [review]
use old tiling method for buggy X servers

Nice catch.
Comment 15 Asa Dotzler [:asa] 2004-09-23 15:54:28 PDT
Comment on attachment 158996 [details] [diff] [review]
use old tiling method for buggy X servers

a=asa for checkin to 1.8a4
Comment 16 tor 2004-09-23 16:02:47 PDT
Checked in on trunk.
Comment 17 Elmar Ludwig 2005-09-13 01:36:16 PDT
The patch does not completely fix the problem here: The commit mentioned in
comment #12 was added to the XFree CVS on 2003-12-09, well after the release
of XFree86 4.3.0.1 on 2003-03-09. Later 4.3.0.x releases might be affected as
well since the commit message on XFree's cvs-commit list indicates that this
was fixed on the trunk only, see:

http://www.mail-archive.com/cvs-commit@xfree86.org/msg02882.html

This means that current Mozilla builds will use the broken code path at least
on XFree86 4.3.0.1 (and probably all 4.3.0.x releases). I can confirm the bad
rendering with XFree 4.3.0.1 and a Firefox 1.5 branch build about a week old,
so I'm reopening this bug now.

> +  if (strstr(ServerVendor(dpy), "XFree86") && VendorRelease(dpy) <= 40300000)
> +    sNeedSlowTile = PR_TRUE;

To be on the safe side, I guess it would be better to check:

  if (strstr(ServerVendor(dpy), "XFree86") && VendorRelease(dpy) < 40400000)
Comment 18 Elmar Ludwig 2005-09-13 01:38:31 PDT
*** Bug 295127 has been marked as a duplicate of this bug. ***
Comment 19 Elmar Ludwig 2005-09-13 01:39:19 PDT
*** Bug 307782 has been marked as a duplicate of this bug. ***
Comment 20 Elmar Ludwig 2005-09-13 02:03:15 PDT
Created attachment 195849 [details] [diff] [review]
use old tiling method also for 4.3.0.x

proposed patch
Comment 21 Boris Zbarsky [:bz] 2005-09-13 08:14:00 PDT
Elmar, you want to request review on patches if you expect them to get noticed... :(
Comment 22 Elmar Ludwig 2005-09-13 09:45:36 PDT
Yeah, I should have seen that I had forgotten something. Thanks for noticing this.
Comment 23 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2005-09-15 18:13:14 PDT
Comment on attachment 195849 [details] [diff] [review]
use old tiling method also for 4.3.0.x

conservative fix, probably worth having on branch
Comment 24 Boris Zbarsky [:bz] 2005-09-16 09:07:47 PDT
Checked that patch in on the trunk.  Elmar Ludwig, thanks for the patch!
Comment 25 Boris Zbarsky [:bz] 2005-09-16 14:03:02 PDT
Fixed on 1.8 branch.

Note You need to log in before you can comment on or make changes to this bug.