bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Status

()

Firefox
Preferences
--
trivial
VERIFIED FIXED
14 years ago
12 years ago

People

(Reporter: Jo Hermans, Unassigned)

Tracking

({helpwanted, polish})

unspecified
PowerPC
Mac OS X
helpwanted, polish
Points:
---
Bug Flags:
blocking-aviary1.5 -
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

14 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.2) Gecko/20040820
Firefox/0.9.1+
Pinstripe theme

The popup that shows fonts in the Font & Colors perferences it too narrow : it
only shows the first 20 characters, but that make it impossible to see the
difference between 'American Typewriter Condensed' and 'American Typewriter
Condensed Light'. I'll post an screenshot immediately.

It was mentioned in bug 204479 comment 12 before.
(Reporter)

Comment 1

14 years ago
Created attachment 156728 [details]
demonstration

Comment 2

14 years ago
it appears as though this issue has spread to the font size pref menus, making
them completely unreadable.  this is occuring on 10.3 for me, and a screen
capture is forthcoming.  perhaps this should be blocking-aviary1.0mac?  it would
seem very un-polished for a 1.0 release without this.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3) Gecko/20040921
Firefox/0.10

Comment 3

14 years ago
Created attachment 159716 [details]
Screen capture of the issue at hand.

Please note that the fonts the previous user has mentioned are in fact still
not viewable in full.
(Reporter)

Comment 4

14 years ago
(In reply to comment #2)
> it appears as though this issue has spread to the font size pref menus, making
> them completely unreadable.  this is occuring on 10.3 for me, and a screen
> capture is forthcoming.  perhaps this should be blocking-aviary1.0mac?  it would
> seem very un-polished for a 1.0 release without this.
> 
> Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3) Gecko/20040921
> Firefox/0.10

I'm not seeing that, but I'm running Mac OS X 10.2.8

Comment 5

14 years ago
Created attachment 159925 [details]
When the language package currently offered from Mozilla Japan is installed.

Although there is no problem with the English version, discernment of a font
will become impossible if a language package is installed.
This is a fatal problem.
(Reporter)

Comment 6

14 years ago
(In reply to comment #5)
> Created an attachment (id=159925)
> When the language package currently offered from Mozilla Japan is installed.
> 
> Although there is no problem with the English version, discernment of a font
> will become impossible if a language package is installed.
> This is a fatal problem.
> 

Since it will immediately affect Japanese users, nominating for
blocking-aviary1.0mac.
Flags: blocking-aviary1.0mac?

Updated

14 years ago
Flags: blocking-aviary1.0mac?
(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.1?
much of this UI has changed... please re-test. Also, renominate if a patch appears. 
Flags: blocking-aviary1.1? → blocking-aviary1.1-
Keywords: helpwanted
Created attachment 177984 [details]
main & adv font prefs window

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050317
Firefox/1.0+

With this build, the main font prefs (left) and advanced font prefs (right)
window still truncate long font names in the pulldown menus.  Also notice how
the sheet for the advanced font prefs is too narrow with the default settings
to completely fit all the buttons on the right.

Comment 9

14 years ago
(In reply to comment #5)
> Created an attachment (id=159925) [edit]
> When the language package currently offered from Mozilla Japan is installed.

It cannot confirm how to become it when the language package is installed
because there is no JLP corresponding to new Preferance yet. 

However, to do this problem in fix, the following content is added as a tentative 
action in 1.0.x release Japanese build. 

ja-JPM.jar:locale/global/intl.css
#serif, #sans-serif, #monospace .menulist-label-box{
  min-width: 200px !important;
}

Comment 10

13 years ago
crot0,
since we have an entity for width of font dialog (see Bug 285570), we can close
this bug, can't we?
Please don't close this bug right now.  The checkins for Bug 285570 happened on
April 20, but the last good trunk build for OS X was April 19.
(Reporter)

Comment 12

13 years ago
(In reply to comment #10)
> crot0,
> since we have an entity for width of font dialog (see Bug 285570), we can close
> this bug, can't we?

No, I still see the situation like attachment 177984 [details].

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050426
Firefox/1.0+
(yes Hanspeter, just released)

Assignee: firefox → nobody
QA Contact: mconnor → preferences
(Reporter)

Comment 14

13 years ago
(In reply to comment #13)
> the checkin from bug 285574 should help.

I don't think so : this bug is about the size of the *popup* menu for the fonts.
(Reporter)

Comment 15

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051104 Firefox/1.5

Much has been promoved - the "default" font-popup is now wide enough for most fonts in the English language pack (Mac OS X 10.2.8), except 4 that are cut off slighly ; in the "advanced" popup, it's only 1.

crot0@infoseek.jp : what's the situation for Japanese users ?

Comment 16

13 years ago
In US/L10N(JP, CN, TW, FI, etc.) build, There is no problem.
There is no problem in build for which an appropriate window width is specified with the following DTD files. 

locale/browser/preferences/fonts.dtd
<!ENTITY  window.macWidth               "45em"><!-- en-US: 43em -->


Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051105 Firefox/1.5
(Reporter)

Comment 17

12 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1b2) Gecko/20060830 BonEcho/2.0b2

This is now a almost-works-for-me, with the default fonts in Mac OS X 10.2.8. Only the 2 first 'American Typewriter' fonts (the condensed ones) are still wider than the popup on the content panel, and you can't see them apart. The popup of the advanced panel is a little wider, and doesn't present a problem.

For me, this bug can be closed, as long as it doesn't present a problem for international users.

Comment 18

12 years ago
Created attachment 236566 [details]
screen shot of Firefox Beta2 ja-JP-mac

It confirmed it in the following packages. 
As for the default font of the contents panel, width is still insufficient. 
In the advance font panel, there is no problem. 

http://www.mozilla.com/products/download.html?product=firefox-2.0b2&os=osx&lang=ja-JP-mac

When the following content is added to userChrome.css, the problem is solved. 
      #defaultFont{width:15em}

It is scheduled to add it to init.css of ja-JP-mac JLP if it doesn't solve it with Firefox.
(Reporter)

Comment 19

12 years ago
ok, then I ask for a blocking flag ; this would not be acceptable for Japanese users.
Flags: blocking-firefox2?

Comment 20

12 years ago
In addition, it checked it. 

The following entry of JLP was wrong when examining it. 
Therefore, this problem occurred. 

http://lxr.mozilla.org/l10n-mozilla1.8/source/ja-JP-mac/browser/chrome/browser/preferences/preferences.dtd#5
    locale/browser/preferences/preferences.dtd
          <!ENTITY  prefWindow.styleMac   "width: 51;"><!-- en-US: 47em -->

# Feedback to JLP is put. 
# http://forums.firehacks.org/l10n/viewtopic.php?p=5197#5197

If this is solved, this bug will be able to be closed. 
Not a regression, not a blocker, feel free to try for an approval if you get a solution (and we should definitely fix the ja-JP issue, file a seperate bug for that and nominate, please)
Flags: blocking-firefox2? → blocking-firefox2-
(In reply to comment #20)
> # Feedback to JLP is put. 
> # http://forums.firehacks.org/l10n/viewtopic.php?p=5197#5197
> 
> If this is solved, this bug will be able to be closed. 

Sorry my typo.
That is solved and now the pulldown box have enought wide for allmost font name.
# though not enough some of the very very long font name
 -> RESOLVED FIXED

If you think this is still not enough, tell me in our forum or reopen this bug.
Thanks.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 23

12 years ago
(In reply to comment #22)
> # though not enough some of the very very long font name
>  -> RESOLVED FIXED

VERIFIED
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ja-JP-mac; rv:1.8.1b2) Gecko/20060913 BonEcho/2.0b2

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.