Current selected printer not saved after print

RESOLVED DUPLICATE of bug 308173

Status

()

Core
Printing: Output
RESOLVED DUPLICATE of bug 308173
14 years ago
13 years ago

People

(Reporter: Pete Zha, Assigned: Pete Zha)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

14 years ago
If you have more than one printer in your print list. Including postscript
printer and xprint printers, you will find the default selected printer is
always the first one of the list. So, you need to select the printer everytime
you print. It very inconvenient.
Steps:
1) Setup more than one printer in your printer list. eg. export
MOZILLA_POSTSCRIPT_PRINTER_LIST="test1 test2 test3 test4"
2) Open Mozilla and open File->Print
3) Select "test3" in the list and click "Print"
4) Open File->Print again

You will find the select printer is "test1" or "Postscript/Default" again

expect result:
Should select "test3" when open the dialog
(Assignee)

Comment 1

14 years ago
Created attachment 156866 [details] [diff] [review]
patch
Assignee: core.printing → pete.zha
Status: NEW → ASSIGNED
(Assignee)

Updated

14 years ago
Attachment #156866 - Flags: superreview?(tor)

Updated

14 years ago
Attachment #156866 - Flags: review?(neil.parkwaycc.co.uk)
(Assignee)

Comment 2

14 years ago
tor,
Seems neil is not available for reviewing. Can you super review this simple
patch and then I can find another people to review it.

Thanks!

Comment 3

14 years ago
Just a comment -- This feature isn't really specific to the postscript driver,
is it? Is it appropriate to put the pref under "print.postscript"?
bug 262287 will fix this problem, too.

Comment 5

13 years ago
Bug 262287 is marked fixed. Is this still an issue?

Comment 6

13 years ago
*** Bug 259612 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
This is very annoying, I am having the same issue with Mozilla 1.7.6 running
on Linux x86_64 with CUPS 1.1.22.
Comment on attachment 156866 [details] [diff] [review]
patch

This patch is wrong.
This is XP bug. not UNIX only.

I try to create the patch in bug 308173. I will fix this bug soon.
Attachment #156866 - Flags: superreview?(tor)
Attachment #156866 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #156866 - Flags: review-

*** This bug has been marked as a duplicate of 308173 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.