Printing reverts to default printer every time a page is printed

RESOLVED FIXED in mozilla1.8beta5

Status

()

Core
Printing: Output
P1
normal
RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: Adam T., Assigned: masayuki)

Tracking

({fixed1.8, regression})

Trunk
mozilla1.8beta5
fixed1.8, regression
Points:
---
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

When printing a page with Firefox <= 1.0.6, if you chose to print any subsequent
pages after the first, Firefox would automatically select the last printer you used.

In Firefox 1.5 Beta 1, every time you print a new Web page, the print dialog
reverts to the default printer as listed in the Printers section of the Windows
Control Panel. This can be annoying if a printer on the network is offline and
you do not want to manually change the default printer for your current browsing
session.

Reproducible: Always

Steps to Reproduce:
1. Navigate to any Web page
2. Select "File -> Print..." from the menubar


Actual Results:  
I realized the printer kept switching back to the default printer!

Expected Results:  
I think the software should behave like its predecessors in that the default
printer should display ONLY if another printer has not been chosen for the
current browsing session. Once another printer has been chosen, it should
persist throughout that session.
I changed to current behavior in bug 118563. I don't think that the default
browser should be selected at first printing in current session...
Assignee: nobody → printing
Component: OS Integration → Printing
Product: Firefox → Core
QA Contact: os.integration
Version: unspecified → Trunk
(Assignee)

Updated

12 years ago
OS: Windows XP → All
Hardware: PC → All
> I don't think that the default
> browser should be selected at first printing in current session...

Sorry.

I don't think that the default printer should be selected at first printing in
current session...
Oops. Sorry. I missed to understand this report.

On currently behavior, we keep the last printer in prefs.js. And next printing
time, last printer is selected and last print setting comes back. In your
environment, Isn't firefox working so?
O.K. I reproduced it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
(Assignee)

Updated

12 years ago
Assignee: printing → masayuki
Flags: blocking1.8b5?
taking. I will create the patch in several days.
Status: NEW → ASSIGNED

Comment 6

12 years ago
Same as bug 256680?
*** Bug 256680 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

12 years ago
Priority: -- → P1
Target Milestone: --- → mozilla1.8beta5
Created attachment 196067 [details] [diff] [review]
Patch rv1.0 for 'javascript:window.print()'
Attachment #196067 - Flags: superreview?(jst)
Attachment #196067 - Flags: review?(jst)
Created attachment 196068 [details] [diff] [review]
Patch for suite
Attachment #196068 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #196068 - Flags: review?(neil.parkwaycc.co.uk)
Created attachment 196069 [details] [diff] [review]
Patch for Firefox(toolkit)
Attachment #196069 - Flags: review?(mconnor)
These patches are very simple.

When |nsPrintSettings| is initialized, it using the value of
"print.print_printer". Therefore, we should save last printer name to here.

# NOTE: I think that if using XP print dialog(toolkit's printdialog.js and
xpfe's printdialog.js), this bug may not be fixed by my patch. Because
printdialog.js has original printing code.(I will test tomorrow or soon, if I
found same problem on XP print dialog, I will file a bug and create the patch.)
(Assignee)

Updated

12 years ago
Whiteboard: [needs review mconnor][needs review jst][needs review neil]

Updated

12 years ago
Attachment #196069 - Flags: review?(mconnor) → review+
(Assignee)

Updated

12 years ago
Whiteboard: [needs review mconnor][needs review jst][needs review neil] → [needs review jst][needs review neil]
Comment on attachment 196067 [details] [diff] [review]
Patch rv1.0 for 'javascript:window.print()'

r+sr=jst
Attachment #196067 - Flags: superreview?(jst)
Attachment #196067 - Flags: superreview+
Attachment #196067 - Flags: review?(jst)
Attachment #196067 - Flags: review+
Comment on attachment 196067 [details] [diff] [review]
Patch rv1.0 for 'javascript:window.print()'

checked-in this.
Attachment #196067 - Attachment is obsolete: true
Comment on attachment 196069 [details] [diff] [review]
Patch for Firefox(toolkit)

checked-in this.
Attachment #196069 - Attachment is obsolete: true
(Assignee)

Updated

12 years ago
Whiteboard: [needs review jst][needs review neil] → [needs review neil]
Could anyone test that checked-in patch works fine or not on Linux(Firefox)?
I cannot test on Linux. Because I cannot add printer to Mozilla.

Updated

12 years ago
Attachment #196068 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #196068 - Flags: superreview+
Attachment #196068 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #196068 - Flags: review+
Comment on attachment 196067 [details] [diff] [review]
Patch rv1.0 for 'javascript:window.print()'

This has very low risk. And it is regression from Firefox 1.0.x(Gecko1.7.x).
This bug is very inconvenience.
Attachment #196067 - Flags: approval1.8b5?
Comment on attachment 196068 [details] [diff] [review]
Patch for suite

See previous comment.
Attachment #196068 - Flags: approval1.8b5?
Comment on attachment 196069 [details] [diff] [review]
Patch for Firefox(toolkit)

See previous comment.
Attachment #196069 - Attachment is obsolete: false
Attachment #196069 - Flags: approval1.8b5?
(Assignee)

Updated

12 years ago
Attachment #196067 - Attachment is obsolete: false
(Assignee)

Updated

12 years ago
Whiteboard: [needs review neil]
Suite's patch is checked-in.
(Assignee)

Updated

12 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Updated

12 years ago
Whiteboard: [needs approval]

Updated

12 years ago
Attachment #196068 - Flags: approval1.8b5? → approval1.8b5+

Updated

12 years ago
Attachment #196069 - Flags: approval1.8b5? → approval1.8b5+

Updated

12 years ago
Flags: blocking1.8b5? → blocking1.8b5+

Updated

12 years ago
Attachment #196067 - Flags: approval1.8b5? → approval1.8b5+
checked-in to branch.
Keywords: fixed1.8
Whiteboard: [needs approval]

Updated

8 years ago
Duplicate of this bug: 395820
You need to log in before you can comment on or make changes to this bug.