The default bug view has changed. See this FAQ.

Message grouping (like threading, but by subject/from/other field rather than by followups)

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
--
enhancement
VERIFIED FIXED
13 years ago
8 years ago

People

(Reporter: Ilyak Kasnacheev, Assigned: Bienvenu)

Tracking

({fixed-aviary1.0})

Trunk
fixed-aviary1.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

It would be very comfortable if mozilla mail could optionally group messages
with same from/subject (Re:'s do not count) into one "thread", so all letters
from each person will be in one "thread", in collapsed threads mode - in one string.

The Bat! have such threading for ages and it is very comfortable.

Reproducible: Always
Steps to Reproduce:
How should it look:
1. Turn on "Group messages by: (list)from".
2. See that all messages from every person are in one thread, easy to list
through and collapse if not needed.
3. Enjoy this fact.

Actual Results:  
Currently, threading can not always cover all messages with same subject, and
never can cover all messages from one address in one thread.
You can, of course, create folder for each correspondent, but this will become
nasty if you have, say, 20 of them.

Expected Results:  
I would be very happy. I hope this will be useful for others.

Updated

13 years ago
Component: Subscribe → Mail Window Front End
(Assignee)

Updated

13 years ago
Assignee: sspitzer → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

13 years ago
Hardware: PC → All
(Assignee)

Comment 1

13 years ago
the initial work on this will land sometime this week.
(Assignee)

Comment 2

13 years ago
Created attachment 161113 [details] [diff] [review]
proposed fix

this patch gets this feature working enough to start banging on...
(Assignee)

Updated

13 years ago
Attachment #161113 - Flags: superreview?(mscott)

Comment 3

13 years ago
Comment on attachment 161113 [details] [diff] [review]
proposed fix

mmm I like reviewing new features right before bed....

1) how about removing the dump in  function MsgToggleThreaded() before checking
in.

2) ditto for MsgSortThreaded

3) Is this going to work for those of us that use the one and only correct sort
order? 

4) I see some more dumps spread out around here. 

5) might be a tab issue in base\src\Makefile.in. They should be real tabs or
linux will break.
Attachment #161113 - Flags: superreview?(mscott) → superreview+

Comment 4

13 years ago
This bug's patch seems to have broken my Thunderbird (Win32/MingW/cygwin) and
(Fedora Core2 w/kernel 2.6.8.1).

The other option is Bug #256668

Comment 5

13 years ago
Text from compile failure.

MsgGroupThread.cpp:35:
e:/mozilla/source/thunderbird/mozilla/mailnews/base/src/nsMsgGroupThread.h:60: e
rror: extra qualification `nsMsgGroupThread::' on member `AddMsgHdrInDateOrder'
ignored
e:/mozilla/source/thunderbird/mozilla/mailnews/base/src/nsMsgGroupThread.cpp:37:
 error: extra `;'
e:/mozilla/source/thunderbird/mozilla/mailnews/base/src/nsMsgGroupThread.cpp: In
 member function `nsresult nsMsgGroupThread::AddMsgHdrInDateOrder(nsIMsgDBHdr*)'
:
e:/mozilla/source/thunderbird/mozilla/mailnews/base/src/nsMsgGroupThread.cpp:170
: warning: unused variable 'topLevelHdrDate'
e:/mozilla/source/thunderbird/mozilla/mailnews/base/src/nsMsgGroupThread.cpp: In
 member function `virtual nsresult nsMsgGroupThread::AddChild(nsIMsgDBHdr*, nsIM
sgDBHdr*, PRBool, nsIDBChangeAnnouncer*)':
e:/mozilla/source/thunderbird/mozilla/mailnews/base/src/nsMsgGroupThread.cpp:209
: warning: unused variable 'parentKeyNeedsSetting'
e:/mozilla/source/thunderbird/mozilla/mailnews/base/src/nsMsgGroupThread.cpp:210
: warning: unused variable 'hdrAddedToThread'
e:/mozilla/source/thunderbird/mozilla/mailnews/base/src/nsMsgGroupThread.cpp:226
: warning: unused variable 'childIndex'
e:/mozilla/source/thunderbird/mozilla/mailnews/base/src/nsMsgGroupThread.cpp: In
 member function `virtual nsresult nsMsgGroupThread::GetChildKeyAt(PRInt32, nsMs
gKey*)':
e:/mozilla/source/thunderbird/mozilla/mailnews/base/src/nsMsgGroupThread.cpp:374
: warning: comparison between signed and unsigned integer expressions
e:/mozilla/source/thunderbird/mozilla/mailnews/base/src/nsMsgGroupThread.cpp: In
 member function `virtual nsresult nsMsgGroupThread::GetChildAt(PRInt32, nsIMsgD
BHdr**)':
e:/mozilla/source/thunderbird/mozilla/mailnews/base/src/nsMsgGroupThread.cpp:382
: warning: comparison between signed and unsigned integer expressions
e:/mozilla/source/thunderbird/mozilla/mailnews/base/src/nsMsgGroupThread.cpp: In
 member function `virtual nsresult nsMsgGroupThread::GetChild(nsMsgKey, nsIMsgDB
Hdr**)':
e:/mozilla/source/thunderbird/mozilla/mailnews/base/src/nsMsgGroupThread.cpp:391
: warning: comparison between signed and unsigned integer expressions
e:/mozilla/source/thunderbird/mozilla/mailnews/base/src/nsMsgGroupThread.cpp: In
 member function `nsresult nsMsgGroupThread::RemoveChild(nsMsgKey)':
e:/mozilla/source/thunderbird/mozilla/mailnews/base/src/nsMsgGroupThread.cpp:411
: warning: comparison between signed and unsigned integer expressions
make[5]: *** [nsMsgGroupThread.o] Error 1
make[5]: Leaving directory `/cygdrive/e/mozilla/source/thunderbird/mozilla/mailn
ews/base/src'
make[4]: *** [libs] Error 2
make[4]: Leaving directory `/cygdrive/e/mozilla/source/thunderbird/mozilla/mailn
ews/base'
make[3]: *** [libs] Error 2
make[3]: Leaving directory `/cygdrive/e/mozilla/source/thunderbird/mozilla/mailn
ews'
make[2]: *** [libs] Error 2
make[2]: Leaving directory `/cygdrive/e/mozilla/source/thunderbird/mozilla'
make[1]: *** [alldep] Error 2
make[1]: Leaving directory `/cygdrive/e/mozilla/source/thunderbird/mozilla'
make: *** [alldep] Error 2
(Assignee)

Comment 6

13 years ago
build bustage should be fixed now.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 7

13 years ago
Confirm, build bustage fixed.....thanks for the quick response.
(Assignee)

Comment 8

13 years ago
fixed on trunk and branch. I'll open new bugs for any remaining issues. To group
messages, pick View | Sort By | Grouped by Sort. We currently can group on date,
subject, sender/recipient, label, and priority.
Keywords: fixed-aviary1.0

Comment 9

13 years ago
David, looks like you missed checking in the new mail/ entities.
(Assignee)

Comment 10

13 years ago
darn, sorry about that, fix checked in on the trunk...

Comment 11

13 years ago
This have added two "may be used uninitialized" warnings (according to brad TBox):

+mailnews/base/src/nsMsgGroupView.cpp:137
+ `PRUint32 ageBucket' might be used uninitialized in this function
+
+mailnews/base/src/nsMsgGroupView.cpp:226
+ `nsMsgViewIndex viewIndexOfThread' might be used uninitialized in this function
+

Comment 12

13 years ago
How is that bug related to Bug 242608? Someone please resolve Bug 242608
duplicate...

Comment 13

13 years ago
*** Bug 242608 has been marked as a duplicate of this bug. ***

Comment 14

13 years ago
*** Bug 238110 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 15

13 years ago
*** Bug 123021 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Updated

10 years ago
Depends on: 371629

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.