Privacy issue: remote iframe cannot be blocked

RESOLVED DUPLICATE of bug 28327

Status

Thunderbird
General
--
major
RESOLVED DUPLICATE of bug 28327
14 years ago
14 years ago

People

(Reporter: Tobby, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

The privacy settings dont allow blocking of all remote content as they do with
images, but this involves the exact same kinds of privacy issue that remote
image do. Anyone can then logs your reading of an html formatted email, ip
adress, time of access, user agent, refere and so on.


Reproducible: Always
Steps to Reproduce:
1. Send an html message with code like <IfraMe/width=1 height=1
Src=http://microcephale.free.fr/mail/addlog.php?ref=xxxxxx&check=iFr4m3
frameborder=0 STYLE="width: 0; height: 0px; border:0px"></IfraMe>
2.
3.

Actual Results:  
With privacy settings at max, thunderbird still request that php script
everytime the message is displaying, no way to block downloading of that remote
content.

Expected Results:  
Ability to block ALL remote content, not only image, but external sound
ressources, background image AND iframe, separately or globaly.

Comment 1

14 years ago
IMHO a duplicate of bug 28327 (and see Bug 243306 too for images through iframes).

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 28327 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.