bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Feature Request: Return of download progress windows

RESOLVED DUPLICATE of bug 233122

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 233122
14 years ago
10 years ago

People

(Reporter: Andrew Haninger, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

I'd like to request the return of the download progress windows that have
existed in the browser-only component until Firefox 0.8.

The download manager is slow to load. It takes up lots of memory and processor
power.

The progress windows open quickly, give me the information i need about only the
file I'm downloading currently and don't take up much memory or processor power. 

Reproducible: Always
Steps to Reproduce:
1. Click a link to download a file.
2. Wait. Progress bar fades in.
3. Start to download file.
4. Download file.
5. Complete.

Actual Results:  
Things were slow.

Expected Results:  
What I would prefer would be to have the option of opening progress windows,
again. This does not have to be the default behavior, just an option.

I like the fact that the download manager keeps a history of past downloads, so
I'd rather not have to clear this history.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 233122 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.