Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 233122 - Option to use separate progress windows instead of download manager
: Option to use separate progress windows instead of download manager
Product: Toolkit
Classification: Components
Component: Downloads API (show other bugs)
: unspecified
: All All
: -- enhancement with 19 votes (vote)
: ---
Assigned To: Ben Goodger (use ben at mozilla dot org for email)
: Ali Ebrahim
: :Paolo Amadini
: 233978 235304 244268 251003 256993 265193 (view as bug list)
Depends on:
  Show dependency treegraph
Reported: 2004-02-04 23:03 PST by Cedric Roijakkers
Modified: 2008-07-31 01:47 PDT (History)
9 users (show)
bugs: blocking‑aviary1.0-
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Cedric Roijakkers 2004-02-04 23:03:51 PST
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040131 Firebird/0.8.0+

In my personal opinion, a feature to be able to completely disable the download
manager would be nice. I'm not talking about not showing the download manager
window like the current option in the 0.8 builds, but like in 0.7, no download
manager at all, and simple dialog boxes asking where the file should be saved or
wether it should be opened by an external program.

To be clear: I'm talking about the 0.7 or IE-like downloading windows, not the
download manager as it is right now. I'm not saying it should be removed, but It
would be better if it could be totally disabled.

Reproducible: Always
Steps to Reproduce:
Comment 1 Jesse Ruderman 2004-02-05 19:58:20 PST
You can already disable the download manager.  Do you want a progress window for
each download in addition to disabling the download manager?
Comment 2 Cedric Roijakkers 2004-02-06 08:04:39 PST
(In reply to comment #1)
> Do you want a progress window for
> each download in addition to disabling the download manager?

That's it, just like it was in Firebird 0.7, and similar like it's in IE now,
instead of having all downloads in the download manager in one window I'd prefer
having them each in their own window, 0.7-style.
Comment 3 Nathan Strom 2004-02-09 14:38:51 PST
I agree w/ the poster here, please bring back the 0.7 behavior which has
separate download windows for each downloading file when download manager is set
not to be shown.
Comment 4 Jesse Ruderman 2004-02-12 19:20:03 PST
*** Bug 233978 has been marked as a duplicate of this bug. ***
Comment 5 Bradley Chapman (not reading bugmail, still gone but not forever) 2004-02-14 02:43:16 PST
I'd just like to say that given the option to use either the separate download
windows or the centralized download manager, I would choose the manager. I know
that the old code has long since been removed, but is the new code designed in
such a way to allow a easy method to restore the old-style downloading system?
Comment 6 Chris 2004-02-14 14:29:01 PST
I agree, there should DEFINITELY be an option to use the old download system,
the new Firefox 0.8 download manager has such poor performance on my computer
that it makes it unuseable.

I never had performance problems with the seperate Firebird 0.7 download windows.
Comment 7 John Lee 2004-02-15 01:43:33 PST
I do not think this should be implemented. Instead, the devs should focus on
solving people's problems with the new download manager. The most frequent
complaints I hear are that it's slow, getting download information isn't as easy
as it used to be, it doesn't open in a tab/in the background and you can't view
download progress from the taskbar. Perhaps RFEs for these bugs would be
appropriate? I have already filed bug 234396 and bug 234397.
Comment 8 Alex Frangis 2004-02-15 13:50:00 PST
I agree with the oringal poster, the old system should be choosable, Ive been 
going through nightly builds of firebird just to try and find the last one 
with the old style download system because the new one, ignoring the bugs it 
has, simply is not what i like to use to download things. The old system 
worked just fine and there was no reason to change it
Comment 9 Charles Fenwick 2004-02-28 21:49:31 PST
*** Bug 235304 has been marked as a duplicate of this bug. ***
Comment 10 gumpish 2004-03-07 16:53:33 PST
(In reply to comment #7)
> I do not think this should be implemented. Instead, the devs should focus on
> solving people's problems with the new download manager.

But the code for the 0.7/IE way of handling downloads has *already been written
and tested*. All that's needed is a boolean in about:config (or a checkbox in
Tools -> Options) to change the path of execution.

Restoring previous functionality should be less labor intensive than "fixing"
the new DM.

The 0.7 way of handling downloads was much more simple, clear and fast, and it
also makes the transition from IE to Firefox/Firebird/Phoenix easier.

I definately think having a DM is "a good thing", for instance if I want to
examine a history of my downloads, but if I'm just downloading a small file (the
download manager doesn't even open for a file if it downloads too quickly,
unless you set a hidden pref) I just want to click the link and then click Open.
Comment 11 Jason Gurtz 2004-03-17 16:28:49 PST
Additional reasons for having the option to switch back to the old seamonkey

-Progress of each concurrent download is immeadiatly viewable in it's taskbar
 button.  It is NOT possible to implement this functionality in a  
 consolidated, single window interface.

-Each Concurrent Download can always be managed with just a single mouse click.
 W/ the DL Manager, sometimes you have to scroll to find the download you want
 to manage.  Fixing this in a consolidated, single window interface, although
 possible, would be a dificult development task and that action would require
 use of a context menu (which are not intuitive to the common person).

-The individual progress dialogs are familier and intuitive to all users
 switching to firefox from Internet Explorer.  The Download manager can not be
 familiar and intuative to these users because it's functionality and use are
 radicaly different.  (This reason supports the DL Manager being a good UI
 option for the advanced user, instead of being turned on by default)

Those are the main points as I see it.  All other complaints seem to be around
the current buggyness of the DL Manager which will no doubt be fixed at some point.
Comment 12 Bruce Robson 2004-03-19 05:06:15 PST
From the Firefox charter
   "Firefox began because a group of people who used to work on the Netscape
browser releases wanted to show the world what a browser would look like if it
were developed using the flexible Gecko layout engine and XPFE, but without the
constraints of commercial interest and the creep of esoteric features from the
developer community."

I do not want a download manager. I rarely download more than two files at the
same time and like having seperate windows for each download. I'm not interested
in a history of all downloads I happen to have made.

I consider a download manager an esoteric feature from the developer community
and that in adding one the developers have broken the Firefox charter.

My main browser is Mozilla and although it has a download manager it has very
little impact on me. In Mozilla, I have the Downloads preference set to "Open a
progress dialog" so the only impact of the download manager is that I periodicly
have to empty the list of downloaded files maintained by the download manager.

Please bring back the seperate download windows for each download and remove (or
 hide) the download manager.
Comment 13 Bradley Chapman (not reading bugmail, still gone but not forever) 2004-03-19 05:23:48 PST
I disagree with you. I do not believe that a download manager is a breach of the
Firefox charter, and it is certainly not an esoteric feature. In fact, if forced
to return to the separate progress window model in 0.9, I would not use 0.9.

I appreciate that there are folks who do not like the new download manager, but
I personally believe that it is a great feature and should be retained if at all

How hard would it be to make the new and old DM outputs coexist solely in the UI
and not in the backend?
Comment 14 Angus Kroll 2004-03-19 05:54:43 PST

We're not asking for the removal of the new DM, just a feature to be able to
turn it off. As stated by Bruce, there are some of us out here that don't
download a lot and definitely don't need the overhead of such an extensive way
to manage something we don't use. I understand there are a majority that likes
the new feature. Great! We simple users are happy that Firefox can be such a
wonderful browser to so many people. I always thought from the beginning that
Firefox (Firebird, Phoenix) was to be a no nonsense, streamlined browser without
all of the "gimmicks". That said, try to understand no one wants to take
anything away from you. We just want an OPTION to turn a new feature off.
Comment 15 Willem Jeffery 2004-03-20 06:58:22 PST
As it is now, the DM seems little more than a crude sketch. But I suppose that's
somewhat to be expected, since it's a brand new feature. No hard feelings :).

I vote for an option to switch between Classic Downloads and the Download
Manager, with Classic as the default. Classic is a robust system, has a good
reputation and, most importantly, It Simply Works. The current DM is none of
those things.

Interestingly though, I would enjoy the look of single DM download item as if it
were a single-download dialogue, 0.7-style. Basically splicing a list of
downloads in the DM into list.length separate Download dialogues, still sporting
the look of a single item. Resize the DM window to fit 1 download to illustrate
what I mean.

So if the option to choose between Classic Downloads and Download Manager is
implementent, the old 0.7 code for download dialogues would not have to be
reinserted, since you could reuse display code for the DM, and modify it
slightly to look like a fixed single-download dialogue. That would also save on
build size.

But all this only after changing the layout for a single item, of course. The
way things look now is not completely conform the FFX style guidelines, i.e.
blue links where buttons or properly styled text 'links' should be, and the
gradient-background Active-state when selecting a download where, in my opinion,
a FFX-blue background or a System color should be. They give the DM a clunky feel.
Comment 16 Ali Ebrahim 2004-04-30 14:49:06 PDT
taking qa
Comment 17 Lonny Eachus 2004-05-10 14:08:11 PDT
I think this has been getting somewhat off the track.

The original complaint was that the Download Manager had some things wrong with
it, AND it could be awkward to use.

(1) The performance can be unacceptably slow, at least on some systems.

(2) The DM window itself also appeared to slow the updating of other windows --
the whole system slowed down.

(3) The little popup signaling end of downloads appears over the system tray.
This is a great annoyance. It is poor placement.

The solution that is clearly most popular / most acceptable:

(1) Allow a toggle to revert behavior back to the 0.7 way of handling downloads,
which was not broken. That handling method offered some benefits, and did not
have performance problems.

Further suggestions:

(1)  Allow use of Download Manager (via toggle -- see above) but gix the
performance / window update problems.

(2)  A toggle to disable the "All downloads finished" popup. At the very least,
it must be moved to a less-critical part of the screen.
Comment 18 Bradley Chapman (not reading bugmail, still gone but not forever) 2004-05-10 15:03:11 PDT
Perhaps some of the complaints can be addressed here?
Comment 19 Lonny Eachus 2004-05-10 15:18:23 PDT
Nice, but it is my understanding that extensions were supposed to be for adding
functionality, not for supplying or repairing fundamental parts of the project.
Comment 20 Bradley Chapman (not reading bugmail, still gone but not forever) 2004-05-11 04:51:21 PDT
Seeing as how this bug has been RESOLVED WONTFIX and blocking1.0-, I suppose
that extensions can do both.

Removing self from CC list.
Comment 21 tloehnert 2004-05-11 09:59:02 PDT
Ben's too young to have a sense for ergonomics ...
Comment 22 Jesse Ruderman 2004-05-21 23:37:17 PDT
*** Bug 244268 has been marked as a duplicate of this bug. ***
Comment 23 Jason Keirstead 2004-05-23 07:30:34 PDT
The link posted above does not even attempt to solve the main complaint in this 
whole thread with the download manager, that you cannot have separate windows 
for each download. We do not all want all the downloads grouped into a bug 
hodgepodge; people who don't spend all day downloading files / have fast 
broadband want to be able to watch the progress of all their downloads in the 
taskbar while doing other things in other windows. 
Comment 24 Cedric Roijakkers 2004-05-23 23:31:20 PDT
It's a shame that this requested feature won't be implemented into FireFox just
because some people (who just happen to be the developers) don't like the
IE/FB0.7 way of downloading files.

I agree that the download manager has been debugged greatly in the last few
weeks (months), but I still like the old way of downloading files, each in a
single window and asking me where I want to save it each time. Not to mention
the increadible uglyness of the "all downloads finished" popup (which luckily
can be disabled now).

Call me arrogant or ignorant, but since quite a lot of people request this it
might be a good idea to just *think* about it, and not just dismiss it because
*you* think it's annoying to have multiple windows. I myself have broadband, am
online all day and download a lot of files, and I still like it the old
fashioned way...
Comment 25 Ali Ebrahim 2004-05-23 23:36:16 PDT
Just a thought that popped into my mind:

What if we had an officially supported extension that enabled this ability, but
that was not part of the default build? Would that be a reasonable compromise?
Ben, any thoughts?

I'm not suggesting this for Firefox 1.0, because there are too many other things
to do, but possibly this could be implemented via extension post-1.0.
Comment 26 Cedric Roijakkers 2004-05-23 23:39:19 PDT
That would definately be an extension that I would be installing. Good call.
Comment 27 Alex Frangis 2004-05-23 23:47:12 PDT
I sit and download all day long on broadband as well and I hate the download
manager. Its sad, but I would rather sit at the last nightly build with the old
manager and accpect its bugs than use the newest Firefox and have loads of
issues fixed. I love to tell others about firefox, but the download manager
confuses too many new users who are used to the IE6 way of doing things when
trying to convert, and its just not what people are used to. Have the new
system, just give us some way to go back to the way we like downloads working
Comment 28 alanjstr 2004-06-06 17:23:20 PDT
This is already handled by an extension.  I know because I use it.
Comment 29 Lev Povalahev 2004-06-06 17:42:48 PDT
(In reply to comment #28)
> This is already handled by an extension.  I know because I use it.

Comment 30 Jason Keirstead 2004-06-06 19:21:10 PDT
(In reply to comment #28)

That extention does nothing to do what this bug is requesting. All it does is
add more junk to the download manager, which is something we do not want at all
( or want the ability to turn off). Please read the bug description.
Comment 31 Ricardo Sánchez-Sáez 2004-06-15 18:07:04 PDT
I myself love Firefox too much, but I know people who do not use it just because
of the download manager. I think an option for reverting back to .7 way of
downloading files it's a must.

That and improving greatly the download manager, for example, some ideas:
- Downloading files should be one line tall, and not two lines and some white space
- Showing windows icons in the download manager is ugly imo
- Downloaded history should provide more information, such as the date of the
- For more ideas on the download manager, check the great, not very overheaded,
fast and stable GetRight (is it a comercial one, and I'm not affiliated with it,
I just happened to use it)
Comment 32 PikeUK 2004-07-12 16:03:04 PDT
*** Bug 251003 has been marked as a duplicate of this bug. ***
Comment 33 kenno 2004-07-13 14:20:22 PDT
For the moment, I stick with 0.7 because of the Download Manager, but I wouldn't
mind upgrading if
- it had the ability to pop up just as fast as the old download window, even on
a Pentium II class machine
- clicking on the "download finished" notification would make it pop up
- it had a "reveal location" option for each newly downloaded file
Comment 34 PikeUK 2004-08-26 08:13:52 PDT
*** Bug 256993 has been marked as a duplicate of this bug. ***
Comment 35 Andrew Haninger 2004-08-26 10:03:41 PDT
Though it's been said a dozen times already, I'm putting in my 2p, too. Please
bring back the OPTION to use separate windows. There is a document
( that says that separate
windows get in the way and are annoying.

On the contrary, they may pop up and get in the way, but I am expecting them. It
is UNEXPECTED popup windows that are annoying.

I say that the current defaults are fine, but the option should be returned to
download files as it was done in Firebird 0.7.

We've been downloading files in webbrowsers for nearly 10 years. In that same
time, computing power and network bandwidth has exploded. And here we are with a
slow, clunky way to do what we were doing in 1995 on our Pentium 75's.

Also, why is it so hard for the developers to see that the current way is
unuseable for many of the users? Hello! Your users are telling you what they
want! And it is not what we're getting.

I love Firefox and would love to see it more widely-used. However, I don't think
I'll want to recommend it when it hits 1.0 if downloading files is so troublesome.

Please bring back those little windows.
Comment 36 kenno 2004-08-28 14:24:17 PDT
While I still think leaving this *option* open would be the most satisfying
solution to my download manager issues, it seems that the devs want to "do the
microsoft", in other words to split the new DM through everybody's throats,
regardless of what the users really want.
So, we might as well suggest improvements for the DM, in order to have its
ease-of-use approach the old download window's. Try to imagine a download
manager where bug 161783, bug 251256, and possibly also bug 132755 and bug
251337 are fixed. Wouldn't its behaviour resemble the old windows enough to make
it acceptable?
Comment 37 Jesse Ruderman 2004-09-20 19:31:28 PDT
*** Bug 244268 has been marked as a duplicate of this bug. ***
Comment 38 Jason Keirstead 2004-09-21 11:22:47 PDT
Ok, I see once again this bug has been marked as WONTFIX.

I am not going to bother opening this again myself since I know someone will
just close it again, but I plead with the developers to *please* open this wish.
This stupid, retaded, always in the way download manager is by far the worst and
most annoying thing in Firefox and it alone is the reason I stopped useing it as
my primary web browser after version 0.7x, and I personally know many other who
feel the same way. If you do not agree with me, just see the bug for many other
opinions, people who would rather use ancient versions than put up with this

I really do not understand the reasoning behind this thinking, which is the
exact opposite of not only every other major web browser in existance, but also
the opposite of Firefox's stated goal - to be "the web, and only the web". How
does a download manager help this? Its just bundling in more garbage that is the
job of a 3rd party application. If I wanted a download manager, there are
umpteen dozen solutions for this in Windows, or Mac, or Unix, any/all of which
are just as good or better than the one in Firefox. However, those of us who *do
not* want them, now have no option at all, instead, they are foxed upon us.

Comment 39 Eugene Savitsky 2004-09-30 17:07:53 PDT
I'm for independant for each download windows also. There should not be an option.
Comment 40 coolynx 2004-10-02 15:11:41 PDT
First of all - I am not against download manager but definetly think that right
now in Firefox download management is in a bad condition. And I think that devs
do not understand the problem. Here are my thoughts about all of this and maybe
something would be helpful.

To solve the problem, first, we ALL have to understand it.

Why do we need a Download manager or download management at all?
1. To see the status of the downloaded file.
2. To cancel/stop/resume the job.
3. To see the full URL of the downloaded file and copy to use it in other
places. For example to copy it to the 3rd party download manager. If it is given
via some scripts and not as a HTML link on a page.
4. To see the history and find some information about previous downloads.

What do we have right now or Facts / Problems:
In all of those cases we have to open the download manager. Can we do all of
those tasks in a FAST and PAINLESS manner? NO!

We understand that Firefox is not a good download manager - it is useless for
"hard" downloads when you got a slow warez/crack/etc. sites with restrictions
and connetion brakes up all the time - it is a pain. It can not do many
automatic tasks and other things that can be easily done with a decent 3rd party
download manager. Because Firefox is a great browser and NOT a download manager.
So, many of us still use a 3rd party download managers.

That's why we could use Firefox mainly for fast downloads. But here we get the
problem - it is damn slow for "fast" tasks. If I have a huge list of downloads
(~1MiB file downloads.rdf or maybe less) it shows up sooooooooooooo slow and
eats up CPU for so long time a user could get frustraded easily, even a browser
or any other program that needs this CPU could crash. Instead of a useful
feature, to do one fast task that a download manager should do, we get a lot of
problems. Huston we have a problem!

Thoughts / Solution:
I think Firefox in near future woun't be able to beat the best download managers
out there. But we have to use it right now.

Many people ask for a separate windows for a downloads. Why? It solves the
problem now and we can do all of those tasks in a fast un painless way.

Firefox downloads.rdf or an XML way of keeping a list of download history is too
slow to load vs. any decent download manager 5 times bigger list that loads in
100 times faster. Maybe the format should be changed if it can not parse XML
format as fast as "some" symbol separated format?

Another solution of not separating downloads in a separate windows would be to
split Download manager into TABS. Make active tab load only active downloads and
when you open DM load only active downloads, so it is fast and you can track all
the activity going on. If a person wants then you can click on second tab where
it loads all the previous downloads and while it loads have a message - please
wait while it loads the download history list.
So split downloads.rdf into two files - downloads-history.rdf and

Still this solution does not solve the main problem with slow XML file parsing
but at least it would be a lot faster for many of us.
Comment 41 Jason Keirstead 2004-10-03 15:40:49 PDT
On October 2, 2004 07:11 pm, wrote: 
> Many people ask for a separate windows for a downloads. Why?  
> Another solution of not separating downloads in a separate windows would be 
> to split Download manager into TABS.  
Argh. No. The reason many people ask for separate windows is so that THEY CAN  
is not going to be any better than the current monstrosity. 
I will say it again - if people want a download manger they can use an  
external one. Firefox should *not* be providing a download manager in any  
way-shape-or form. It is not what casual internet users want, expect, or  
Comment 42 Ali Ebrahim 2004-10-20 00:54:59 PDT
*** Bug 265193 has been marked as a duplicate of this bug. ***
Comment 43 Jason Gurtz 2005-01-14 14:45:51 PST
Any chance on this getting into 2.0?
Comment 44 Marc Richter 2005-01-15 01:15:51 PST
> I will say it again - if people want a download manger they can use an  
> external one. Firefox should *not* be providing a download manager in any  
> way-shape-or form. It is not what casual internet users want, expect, or  
> need.


I can't understand why this is an "Won't Fix" marked Bug!!!
You're aiming to become the most popular Webbrowsing application in the world.
So - shouldn't you care a little bit more about the needs and wishes of the users?

Why are you saying "No - I like it this way better, so EVERYONE has to use it
that way?" isn't that a little ... Microsoftish?

Another thing I don't understand is, that it shouldn't become a absolute change
in the way FF behaves, it shal be an additional feature instead, so that you can
choose between single DL windows and the manager.
Isn't such a choosing ability the way "free" Software should behave?

Note You need to log in before you can comment on or make changes to this bug.