Status

()

--
critical
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: si.andrews, Assigned: bugzilla)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

Been using Firefox for a while now, but recently the browser has been crashing
an awful lot.
Doesn't matter if its viewing a page, or if I have any tabs open - it will crash
at random times. I've tried re-installing the browser, logging in with a
different profile. It happens even with no other apps running. I also installed
it on another Hard-drive [and different partitions] with the same results.

Browser version: 0.9.2 [I've also tried 0.9.3 with the same results]
Operating System: XP Pro

Below is a screen shot:
http://www.nirvana28.demon.co.uk/firefox.jpg

Have also posted the fault below, with no real resolution

Reproducible: Always
Steps to Reproduce:
1. Just opening the brower will make this problem happen at randon times
2.
3.

Actual Results:  
Browser will give me this error:
http://www.nirvana28.demon.co.uk/firefox.jpg

I click on the button to report the fault

Expected Results:  
Should not of crashed

See here:

http://www.nirvana28.demon.co.uk/firefox.jpg
Your screenshot looks like the Windows error report. To help diagnose this
problem you need to provide some Talkback reports, since they provide Firefox
specific information. Talkback is installed by default, but perhaps you disabled
it during a custom installation. Please reinstall in that case. 

Each report has an ID that should be posted in this bug, and then add the
"talkbackid" keyword.

(Reporter)

Comment 2

14 years ago
Created attachment 157182 [details]
actual screen I get when browser crashes

This new screen capture it the error screen which first appears when the
browser crashes
(Reporter)

Comment 3

14 years ago
Created attachment 157183 [details]
Talkback screenshot

You requested I provide a talkback report.
Wasn't 100% sure where to add the info, so through a screen grab would be best

HTH
(Reporter)

Comment 4

14 years ago
Another Talkback [incident] ID:
TB670987X
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB670363G
Talkback incident.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Browser crashing at random times → Browser crashing at EditAggregateTxn::QueryInterface
Well, this is happening at different places. Are you sure this is not a problem
with your machine in general?
Summary: Browser crashing at EditAggregateTxn::QueryInterface → Browser crashing
(Reporter)

Comment 7

14 years ago
(In reply to comment #6)
> Well, this is happening at different places. Are you sure this is not a problem
> with your machine in general?

Machine seems very stable atm, also tried on another HD with the same problem.

The URL in Comment #5, does that show where the problem is happening? Can see it
states which Line is the issue, but I wouldn't know how to interpret that.

Had another Incident ID: TB671479M, it states, Trigger Reason - Access violation
(Reporter)

Comment 8

14 years ago
Forgot to say IE6 and Opera 7.54 work fine.
Just got another crash : TB671673H [Access violation again]
(Reporter)

Comment 9

14 years ago
Had some more crashed today:

TB678057G
TB677859G 
TB676566K
TB675664X
TB674522Y
TB674398K
TB674139G
TB674130E

Updated

14 years ago
Keywords: crash

Comment 10

14 years ago
reporter: virtually none of your crashes are the same.

create a bookmark
name it 'talkback-public'
enter:
<http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=%s>
as the url
assign 'tb' for its keyword.
quit (to save your newly added bookmark).

each time you crash and get an incident from talkback, load |tb <thatincident>|
you'll get a page which lists a stack trace at the bottom.

clicking on the first frame should give you a list of all bugs which have that
signature, for example

load: tb TB677859G
you end up at:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB677859G
click 
nsStyleContext::~nsStyleContext
you end up at:
http://bugzilla.mozilla.org/buglist.cgi?query_format=&long_desc_type=substring&long_desc=nsStyleContext::~nsStyleContext&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&emailassigned_to1=1&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=noop&type0-0-0=noop&value0-0-0=
the crashes listed there seem to be fairly old and are all resolved, so, file a
new bug. if you ever have steps to reproduce, include them. otherwise filing a
bug only enables you to track the crash in the event someone else runs into it
later (or decides to fix your crash).

Comment 11

14 years ago
one notable exception, TB674522Y:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB674522Y
the results list three bugs, only one is still alive today, Bug 148928
although in that case, the stack traces aren't similar so it's probably just a
coincidence and a new bug would be more appropriate. today, fwiw, the CToken
constructor does nothing of interest, so the problem is probably related to its
arena.

Comment 12

14 years ago
Crashes when browsing through Sony's XBR Television website. Try it for yourself.
Here's the link :
http://www.sonystyle.com/is-bin/INTERSHOP.enfinity/eCS/Store/en/-/USD/SY_DisplayProductInformation-Start?CategoryName=xbr_tube&Dept=tv&ProductSKU=KD34XBR960

Just scroll the 3D presentation of the TV powered by Viewpoint. It will suddenly
crash. Thank You.

Updated

14 years ago
Blocks: 269832

Comment 13

14 years ago
In Firefox version 1.0.4 this bug is still unfixed.

Comment 14

14 years ago
WFM on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050530
Firefox/1.0+

(In reply to comment #12)
> Crashes when browsing through Sony's XBR Television website. Try it for yourself.
> Here's the link :
>
http://www.sonystyle.com/is-bin/INTERSHOP.enfinity/eCS/Store/en/-/USD/SY_DisplayProductInformation-Start?CategoryName=xbr_tube&Dept=tv&ProductSKU=KD34XBR960
> 
> Just scroll the 3D presentation of the TV powered by Viewpoint. It will suddenly
> crash. Thank You.

It's Bug 208555.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.