Closed Bug 257317 Opened 17 years ago Closed 17 years ago

Fullscreen window management buttons need tooltips

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set
trivial

Tracking

()

RESOLVED FIXED

People

(Reporter: ross, Assigned: sipaq)

References

Details

(Keywords: fixed-aviary1.0, late-l10n, Whiteboard: [needed-aviary] [l10n impact])

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040825 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040825 Firefox/0.9.1+

The buttons that appear in the top-right of the window when in fullscreen mode
don't have any tooltips.

On Windows, these need the (localisable) tooltips
* "Minimize"
* "Restore"
* "Close"
...to be in line with IE6.

Reproducible: Always
Steps to Reproduce:
1. Enter fullscreen mode
2. Hover over one of the standard three buttons at the top left of the screen.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 258823 has been marked as a duplicate of this bug. ***
Attached patch Patch v1 (obsolete) — Splinter Review
Assignee: bugs → bugzilla
Status: NEW → ASSIGNED
Attached patch Patch v2 (obsolete) — Splinter Review
Forgot the ; at the end of tooltip
Attachment #159318 - Attachment is obsolete: true
Comment on attachment 159319 [details] [diff] [review]
Patch v2

>+<!ENTITY fullScreenClose.tooltip "Close">
>+<!ENTITY fullScreenRestore.tooltip "Restore">
>+<!ENTITY fullScreenMinimize.tooltip "Minimize">

Change the order on these so they're not in reverse order, and r=me
Attachment #159319 - Flags: review+
Attachment #159319 - Attachment is obsolete: true
Comment on attachment 159336 [details] [diff] [review]
incorporating mconnor's review comments

Bringing mconnor's review over.
Attachment #159336 - Flags: review+
Checked into trunk 2004-09-18 15:24.
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Whiteboard: [needed-aviary] [l10n impact]
Comment on attachment 159336 [details] [diff] [review]
incorporating mconnor's review comments

Would be nice for 1.0.
Has l10n impact because it adds 3 new strings.
Attachment #159336 - Flags: approval-aviary?
I just saw the notice on the aviary tinderbox page.
bsmedberg, this affects l10n. Can you approve this, please?
asa/chofmann must approve this as well, but I'm ok with it landing as long as it
happens soon.
Comment on attachment 159336 [details] [diff] [review]
incorporating mconnor's review comments

a=asa for aviary checkin.

Please add the late-l10n keyword and notify our localizers in the npm.l10n
newsgroup of this change. thanks.
Attachment #159336 - Flags: approval-aviary? → approval-aviary+
Keywords: late-l10n
Checked into aviary.
Checking in base/content/browser.xul;
/cvsroot/mozilla/browser/base/content/browser.xul,v  <--  browser.xul
new revision: 1.228.2.2.2.37; previous revision: 1.228.2.2.2.36
done
Checking in locales/en-US/chrome/browser/browser.dtd;
/cvsroot/mozilla/browser/locales/en-US/chrome/browser/browser.dtd,v  <-- 
browser.dtd
new revision: 1.1.2.27; previous revision: 1.1.2.26
done
Keywords: fixed-aviary1.0
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.