inconsistent keyboard shortcut handling while in text fields

VERIFIED DUPLICATE of bug 189615

Status

()

--
minor
VERIFIED DUPLICATE of bug 189615
14 years ago
14 years ago

People

(Reporter: jmoses, Assigned: aaronlev)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

There's inconsistent ( i think ) keyboard shortcut handling in text fields. 
Both in webpages, and text fields in the application (location/search) as well.

It seems that, while the focus is in a text field, text based keyboard shortcuts
take precedence over application based shortcuts.

For example, CTRL+W deletes the last word, rather than closing the current tab.

I think that this is fine when the focus is in form fields in the actual page,
but seems counter-intuitive when the focus is in application fields, such as the
Location or Search bars.

This causes such issues as, when I mistakenly open a new tab, and it opens in
front of the tab I was viewing, I can't just hit CTRL+W to close it, I have use
the mouse to take the focus away from the location bar before I can close the tab.

I'd like to see the application preferences take precedence in the application
text fields, rather than text shortcuts.  Or at least, a hidden preference to
change this behavior.

I also can't really decide if this is a minor bug, or a enhancement request.  oh
well.

Reproducible: Always
Steps to Reproduce:
1. Put focus in location bar.
2. Press CTRL+W (close tab)

Actual Results:  
last word type deleted

Expected Results:  
tab closure
(Reporter)

Comment 1

14 years ago
*** Bug 257548 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

14 years ago
This should probably marked a DUP of bug 189615 or bug 72352. Someone look at
those and determine whether we need to keep this as a separate bug.
Duping to firefox bug.

*** This bug has been marked as a duplicate of 189615 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Verifying old and obvious dupes. Sorry for bugspam.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.