http Download doesn't download anything

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: hans, Unassigned)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.8a3) Gecko/20040901
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.8a3) Gecko/20040901

When I click a file for download (like in the URL I gave above) the download
doesn't start. Note that under Preferences/Navigator/Downloads, I selected "Open
a progress dialog" so this isn't a download manager issue.

Reproducible: Always
Steps to Reproduce:
1. Click a download link (like the URL for this bug) - or - shift-click it
2.
3.

Actual Results:  
When I left-click the link, a messagebox opens saying "<temp>\<junk>.exe could
not be saved, because the source file could not be read. Try again later, or
contact the server administrator." where <temp> is the path to my Temp dir, and
<junk> is a random 8-character string.
When I shift-left-click the link, a "save as" dialog opens but when I click OK,
nothing happens.

Expected Results:  
As for left-click, a dialog should open asking whether I want to save or
download the file. As for shift-left-click, the download progress window should
have opened. In both cases, the file should be transferred to my computer.

This bug was not present in version 1.8.0.2004082508. It also seems to prevent
E-mail attachments from being opened, but they can be saved by using the
right-click context menu.
(Reporter)

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 256962 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
reopening, the bugs are differnet.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

15 years ago
Do you see any errors in the Javascript Console (under Tools - Web Development)?
(Reporter)

Comment 4

15 years ago
Nope. No JavaScript errors.
(Reporter)

Comment 5

15 years ago
Two more things. First, right-click -> save link location works in the expected
way. Second, with build 2004-09-06-06, the problem's gone. Marking WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.