Closed Bug 258027 Opened 16 years ago Closed 10 years ago

A file queue would be a useful tool for downloading multiple files from a single site.

Categories

(Toolkit :: Downloads API, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 168734

People

(Reporter: mmoore, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: 

A file queue would be a useful tool for downloading multiple files from a single
site.

Instead of automatically beginning all downloads, or stacking the selections
blind if the max downloads setting is reached, it would be nice to have a
visible list of files selected for download in the file queue.  It could be as
simple as a check box on the Execute/Save popup.  In the queue list it would
show all files, and their position in the queue.  This way if a site has limited
upload (dsl, cable modem, etc) you can grab multiple files, but still maximize
bandwidth for each download.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
similiar Seamonkey bug is Bug 168734
Very similar.  My bad, I searched but didn't find this one.  I went a little
simpler with a check box instead of prefs but essentially the same.
*** Bug 270733 has been marked as a duplicate of this bug. ***
Depends on: 168734
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 284863 has been marked as a duplicate of this bug. ***
QA Contact: ali → download.manager
Assignee: bugs → nobody
Product: Firefox → Toolkit
Status: NEW → RESOLVED
Closed: 10 years ago
No longer depends on: 168734
Resolution: --- → DUPLICATE
Duplicate of bug: 168734
You need to log in before you can comment on or make changes to this bug.