Mail View Headers All - Normal stuck on Normal

RESOLVED DUPLICATE of bug 258143

Status

--
major
RESOLVED DUPLICATE of bug 258143
14 years ago
10 years ago

People

(Reporter: jay, Assigned: Bienvenu)

Tracking

({regression})

Trunk
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040814
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040814

I just updated from Mozilla 1.6 to 1.7.2.
We are Linux RedHat 8

View Headers All/Normal does not function.  It shows Normal as selected (and
that is the result), but all attempts to change to All are fruitless; the
selection does not change and the appearance on screen does not change.

Reproducible: Always
Steps to Reproduce:
1. On main mail menu, View, Headers
2. Select All
3.

Actual Results:  
Nothing at all.  The appearance of the headers did not change. When I repeat the
process, the setting is still on Normal.  It did not change to All.  (The
headers are expanded, i.e. they are in a vertical list of four items and have a
"-" control.)

Expected Results:  
The headers should have been expanded to show all headers.  The menu should show
All selected instead of Normal.

I don't think there is anything special about our configuration.  We are not
doing anything special or custom that I am aware of.

In case it is somehow relevant, since it relates to email headers, I have just
put a comment on Bug 181527 stating that when we PRINT emails (since this update
to 1.7.2) the TO header does not print and does not show in Print Preview either.

Comment 1

14 years ago
confirmed with linux trunk 2004090506.  

###!!! ASSERTION: trying to load nsMsgViewIndex_None: 'aViewIndex !=
nsMsgViewIndex_None', file nsMsgDBView.cpp, line 1029

this is a regression from bug 11051.  nsMsgDBView::ReloadMessageHelper does:

    m_currentlyDisplayedViewIndex = nsMsgViewIndex_None;
    LoadMessageByViewIndexHelper(m_currentlyDisplayedViewIndex, forceAllParts);

LoadMessageByViewIndexHelper exits immeadiately if m_currentlyDisplayedViewIndex
== nsMsgViewIndex_None
Assignee: sspitzer → bienvenu
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → Mail Database
Ever confirmed: true
Keywords: regression

Comment 2

14 years ago
ah.  1.7.2 was from before the regression I was seeing.  I'll file a new bug
Assignee: bienvenu → sspitzer
Component: Mail Database → Mail Window Front End
Keywords: regression

Comment 3

14 years ago
Reassinging to bienvenu as it's his regression.

IMHO reloading the message by view index doesn't really work anyway, because
it's too easy to change the view index of the currently displayed message:
* change the sort order or direction
* expand or collapse threads above the current message
* new messages inserted or messages deleted above the current message

Reloading the message by message key didn't work either, because the key doesn't
know which folder it's in. Maybe using m_currentlyDisplayedMsgUri would help?

I happened to notice a bug in SetSuppressMsgDisplay; if you have multiple
messages selected then the first one gets loaded when you unsuppress the
display, although normally multiple messages clear the message pane.
Assignee: sspitzer → bienvenu
Component: Mail Window Front End → Mail Back End
Keywords: regression

Comment 4

14 years ago
I think this should be marked a dupe of bug 248143 - it's a higher number, but
David's already posted a comment there saying that he's about to look at it.

*** This bug has been marked as a duplicate of 258143 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 5

14 years ago
Apologies - but 258143.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.