Closed Bug 258167 Opened 16 years ago Closed 15 years ago

Firefox doesn't load document/stylesheet when you use the \ in the link.

Categories

(Firefox :: General, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 64488

People

(Reporter: eghuizen3, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

If you use <link href="..\styles.css" rel="Stylesheet" type="text/css"> it won't
load, but when you use <link href="../styles.css" rel="Stylesheet"
type="text/css"> it would load. Ik know that de \ is not correct to use in an
url, but when you use dynamic links and you're not good with computers, you type
it wrong and then it won't load. For some beginners it is not a good thing.

This "bug" is also known with images and url's. If you have a link to an other
page (like. images\image.aspx) then it does work, but then when you use on that
pages aan img tag like this: <img src="..\pics\pic.jpg"> it won't work, because
he uses the wrong base directory.

Reproducible: Always
Steps to Reproduce:
1. put a stylesheet in your basemap
2. put a webpage in a submap wich uses your stylesheet in the base map
3. but use this location: ..\stylesheet.css and not ../stylesheet.css

Actual Results:  
Won't load the stylesheet.

Expected Results:  
Also use the \ als directory splitting (like Internet Explorer). If you want to
use the \ in a url als data you can always use urlencode.
This is basically the same issue as bug 121839, suggest WONTFIX.

*** This bug has been marked as a duplicate of 121839 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 250449 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago15 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 64488 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
--> Websites :: www.mozilla.com so timeless can close out Firefox :: Product Site.
Component: Product Site → www.mozilla.com
Product: Firefox → Websites
-> Firefox::General (939393)
Component: www.mozilla.com → General
Product: Websites → Firefox
You need to log in before you can comment on or make changes to this bug.