Status

()

Core
Layout
P3
critical
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: Edward Brown, Assigned: harishd)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
I've noticed that if a web page has a tag like this:

<a href="http://a.site.com"><font size=3>A Site</a>

Mozilla crashes and doesn't read the '</a>' tag.

Everything else on the page becomes linked to that anchor.

The </font tag must be used prior to the </a> tag.
Other browsers allow for font tag nesting and other trickery.
Ed
(Assignee)

Comment 1

18 years ago
Moving to my list.
Assignee: rickg → harishd
(Assignee)

Comment 2

18 years ago
Created attachment 4746 [details]
Reduced case.
(Assignee)

Comment 3

18 years ago
Created attachment 4747 [details]
Screen shot..
(Assignee)

Comment 4

18 years ago
The content-model:

docshell=00ED9910
html@0125212C refcount=3<
  head@012521DC refcount=2<
  >
  body@0120257C refcount=3<
    a@01214E2C href=http://a.site.com refcount=3<
      font@0121431C size=3 refcount=3<
        Text@01214830 refcount=3<linked >
      >
    >
    Text@01215120 refcount=3<not linked\n>
  >
>
(Assignee)

Comment 5

18 years ago
Could you tell me which build you are using? Because I don't see any of the 
problems you mentioned.
(Assignee)

Comment 6

18 years ago
Not able to reproduce the problem. Marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Updated

18 years ago
Keywords: verifyme

Comment 7

18 years ago
Works for me in the April 20th build.
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout

Updated

10 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.