Importing Opera bookmarks fails when ooera6.adr stored in a custom location

RESOLVED INVALID

Status

()

Firefox
Migration
RESOLVED INVALID
14 years ago
4 years ago

People

(Reporter: Luke Shingles, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040907 Firefox/1.0 PR (NOT FINAL)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040907 Firefox/1.0 PR (NOT FINAL)

I keep my Opera bookmarks file in My Documents instead of \Documents and
Settings\username\Application Data\Opera\profile\. Firefox doesn't find my
bookmarks because they are not in the expected location. The actual location of
the bookmark file can be found in opera6.ini in the Opera profile directory under:

[User Prefs]
Hot List File Ver2=C:\My Documents\opera6.adr

Reproducible: Always
Steps to Reproduce:
1. In Opera go to Bookmarks, Manage Bookmarks. 
2. Click the "File" dropdown button and choose "Save as".
3. Choose a new location for the bookmark file.
4. Open Firefox and go to File -> Import
5. Select the Opera radio button
6. Click Next
Actual Results:  
The Bookmarks option is not listed.

Expected Results:  
The location of the bookmark file should be found in Opera6.ini
(Reporter)

Updated

14 years ago
Version: unspecified → 1.0 Branch
I don't see any way to change this from within the Opera preferences dialog.  Do
you have to hand-edit the opera6.ini to change the location?  If that's the case
then this isn't a critical fix for 1.0.

Relevant places that would need to be fixed:
http://lxr.mozilla.org/aviarybranch/source/browser/components/migration/src/nsOperaProfileMigrator.cpp#368
Somewhere in CopyPreferences the bookmarks file location needs to be parsed out.

http://lxr.mozilla.org/aviarybranch/source/browser/components/migration/src/nsOperaProfileMigrator.cpp#994
Needs to use the directory gathered from the prefs file instead of the profile dir.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> I don't see any way to change this from within the Opera preferences dialog.  
Do
> you have to hand-edit the opera6.ini to change the location?  If that's the 
case
> then this isn't a critical fix for 1.0.

Read my instructions, it's changed through Opera's bookmarks manager.

Comment 3

13 years ago
This information might also be helpful.  I am running Opera 7.6.  When Opera is
installed, the user is asked whether it should be installed for ALL users or for
the particular user who is logged on.  If it is installed for ALL users, the
Opera preferences and bookmarks are stored in the c:\program
files\opera7x\profile\ directory.  Only if it is installed for a single user,
the bookmarks are stored in c:\
Documents and Settings\username\Application Data\Opera\Opera7x\ .  I saw that
when using Firefox's import utility, the utility was ONLY looking in the
Application Data directory and not also in the Program Files directory.  So I
copied the profile directory over to the Application Data directory, re-ran
Firefox's import, and it then showed up as an available profile and was
successful.  

Comment 4

13 years ago
(In reply to comment #0)

> I keep my Opera bookmarks file in My Documents instead of \Documents and
> Settings\username\Application Data\Opera\profile\. Firefox doesn't find my
> bookmarks because they are not in the expected location. 

It would also be good to have the possebility to manually direct Firefox to the
neccessary files as i.e. in my case, I don´t have Opera installed, but the
bookmarks and password lists are still saved in a documents folder. Migration is
thus not possible. I can´t import them as Firefox is looking for installed
software only. 

Suggested solution: Add a data browser option to the import script, enabling
users to manually choose and define files (i.e. Opera notes.adr as "quicknotes"
component) to import them.

Comment 5

12 years ago
This bug still remains in the "1.5" branch of Firefox.

Updated

12 years ago
Version: 1.0 Branch → Trunk
Assignee: bugs → nobody

Updated

6 years ago
Depends on: 707601
Status: NEW → RESOLVED
Last Resolved: 6 years ago
No longer depends on: 707601
Resolution: --- → INVALID

Updated

4 years ago
tracking-firefox25: --- → ?
tracking-firefox25: ? → ---
You need to log in before you can comment on or make changes to this bug.