Closed Bug 707601 Opened 11 years ago Closed 2 years ago

Rewrite Opera profile migration in js

Categories

(Firefox :: Migration, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1284106

People

(Reporter: m_kato, Unassigned)

References

Details

Attachments

(1 obsolete file)

+++ This bug was initially created as a clone of Bug #539133 +++

Opera profile migration doesn't work well because current code seems to be for Opera 6.

- reimplemented by JS (we may require ini parser by js)
- use async as possible for performance and chromehang
- test harness like bug 706017
(In reply to Makoto Kato from comment #0)
> - reimplemented by JS (we may require ini parser by js)

We have nsIINIParser, FWIW.
Summary: Rewriting Opera profile migration → Rewrite Opera profile migration
Duplicate of this bug: 257445
Duplicate of this bug: 434851
maybe this bug depends on  Bug #718608 ?
yes
Depends on: 718608
Summary: Rewrite Opera profile migration → Rewrite Opera profile migration in js
Blocks: 357898
Blocks: 462129
Blocks: 462130
Blocks: 397771
Blocks: 258372
Blocks: 260194
Blocks: 351049
Blocks: 394273
No longer blocks: 462130
Duplicate of this bug: 462130
No longer blocks: 258372
No longer blocks: 260194
No longer blocks: 351049
No longer blocks: 357898
Makoto Kato, I assume you aren't working on this?

I wonder whether we should WONTFIX. I suppose some Opera users may be abandoning it soon given their recent announcement, but I'm not sure this is worth the effort even still.
No longer blocks: 394273
Duplicate of this bug: 394273
Attachment #8895572 - Attachment is obsolete: true
Flags: needinfo?(MAWAVANSMOOKEY)

Opera is based on Chromium now so we would subclass the Chromium migrator if we wanted Opera import support (bug 1284106)

Assignee: m_kato → nobody
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1284106
You need to log in before you can comment on or make changes to this bug.