horizontal rule floats inside table

VERIFIED DUPLICATE of bug 18754

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED DUPLICATE of bug 18754
18 years ago
18 years ago

People

(Reporter: Egor Duda, Assigned: buster)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
horizontal ruler has correct size, but is aligned relative to full window width, 
not the 10% width left from table. could it be because of the same reason as in 
bug #25787?
(Reporter)

Comment 1

18 years ago
Created attachment 4735 [details]
testcase

Comment 2

18 years ago
Adding a border to the floating table shows that the hr appears inside it. The 
line box containing the hr has an origin that causes this. Steve, I'll let you 
decide if this is a dup of 25787. 
Assignee: karnaze → buster
(Assignee)

Comment 3

18 years ago
floater issues will be handled in M16
Target Milestone: M16

Comment 4

18 years ago
Attaching another testcase which is  a) valid HTML  b) illustrates the problem
better (the horizontal rule should be outside the table).

I saw this bug on a Linux build couple of weeks ago, too - changing Platform/OS
to All/All.  Also updating Summary and removing the dead URL.

It works for me now on Linux (build 2000-05-08-11).  Will check Win32 build
soon.
OS: Windows NT → All
Hardware: PC → All
Summary: horizontal ruler aligned incorrectly on page w/table → horizontal rule floats inside table

Comment 5

18 years ago
Created attachment 8585 [details]
improved testcase

Comment 6

18 years ago
I must have been hallucinating.  The bug is still very much there, both on
Linux (2000-05-08-11) and WinNT4 (2000-05-08-08).

Wouldn't this be closer to Style System than HTMLTables?
Component: HTMLTables → Style System
(Assignee)

Comment 7

18 years ago
mass-moving all remaining M16 bugs to M17
Target Milestone: M16 → M17

*** This bug has been marked as a duplicate of 18754 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
Verified dup of 18754
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.