forwarded emails are "named" like the subject

RESOLVED DUPLICATE of bug 220646

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 220646
14 years ago
11 years ago

People

(Reporter: Otto Jongerius, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7) Gecko/20040617 Firefox/0.9
Build Identifier: User-Agent: Mozilla Thunderbird 0.7.3 (Windows/20040803)

If I forward emails they get attached and named exactely like the subject. 
I understand that filenames should not be changed but when you take the subject
of an email there is a bigger chance of mailservers bouncing mail by someone
forwarding an email with a subject ending with ".com" 
Our "solution" was to let the user use our webmail -Squirelmail, which attaches
.msg to the subject line. Other clients (mutt, outlook, outlook express) behave
"correctly" too. I understand this behaviour is not perse *wrong* but a lot of
mailservers out there bounce  -or strip parts of, mail that carries parts with
names that end with .exe, .com etc.

Reproducible: Always
Steps to Reproduce:
1. forward an email which ends with .com or any other -not that I know of any
top level domains that is a common executable extension too
2. send it to a destination that receives a lot of **** and uses body_checks
that filter out attachments that look like suspicious filenames to take the load
of the server.
3. notice that the forwarded message is removed or the message bounces.
Actual Results:  
The mail gets bounced by servers that are a little too strict.

Expected Results:  
Attach something like .msg to the name would be neater.

Comment 1

14 years ago
Fixing bug 220646 would solve this problem.

Updated

14 years ago
Status: UNCONFIRMED → NEW
Depends on: 220646
Ever confirmed: true

Comment 2

13 years ago
Marking as dupe of bug 220646, the fix there solves this problem too.

*** This bug has been marked as a duplicate of 220646 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
No longer depends on: 220646

Updated

11 years ago
Duplicate of this bug: 271211
You need to log in before you can comment on or make changes to this bug.