If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Site icon (favicons) vertically mis-aligned in location bar when changing system font size

NEW
Unassigned

Status

Camino Graveyard
Toolbars & Menus
--
trivial
13 years ago
8 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Unassigned)

Tracking

(Blocks: 1 bug)

Details

Attachments

(2 attachments)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.2) Gecko/20040825 Camino/0.8.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.2) Gecko/20040825 Camino/0.8.1

Favicons (and the globe and document icons for sites and local files) are
vertically "mis-aligned" in the location bar--aligned to the bottom of the bar
rather than centered like the URL text, leaving excess white space above the
favicon and almost making the favicon look like it is covered up by the grey
"border" on the bottom.  It's visually distracting (but trivial) :-)

Reproducible: Always
Steps to Reproduce:
1.  Open Camino
2.  Look at the Location bar
3.

Actual Results:  
Globe/favicon vertically aligned with the bottom of the location bar

Expected Results:  
Globe/favicon should be vertically centered in location bar, along with URL
text--which is centered.

Mac OS X 10.3.5, Camino 0.8.1
Created attachment 158278 [details]
small screenshot of the relevant area
I just noticed this mis-alignment occurs in the tabs, too (it's less
noticeable).  Does that need a separate bug?

Comment 3

13 years ago
Never seen this, never heard of it. Pleas dl a new build of Camino and try again.
WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 4

13 years ago
Seems this is caused by the user changing the system font size.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Updated

13 years ago
Status: UNCONFIRMED → NEW
Component: Location Bar & Autocomplete → Toolbars & Menus
Ever confirmed: true
Created attachment 160418 [details]
Favicon overlaps the focus ring/highlight

Ah...yes, I had decreased a couple of font sizes by one point via TinkerTool
when I first got OS X.	It helped with Apple's UI size bloat but I'd never seen
an ill effect--until now.

Here's an even better illustration from the 20040925 build.

(Jasper, what does "WFM" mean?)
Having spent some time now helping try to triage, dupe, reproduce, etc., other
bugs, I think the summary would be more useful if it reflects the cause that
Jasper discovered.  So changing the summary to add "when system font size changed."

Sorry for the interruption.

Summary: favicons vertically mis-aligned in location bar → favicons vertically mis-aligned in location bar when system font size changed

Comment 7

13 years ago
How do you change the system font size? Is there UI to do this?

Comment 8

13 years ago
No there is no UI for this in the system, people do this using Haxies I guess.
I'm in favour of WONTFIXING this bug. This probably only happens to 0.5% of our
users.
A number of 3rd party tools such as TinkerTool provide the UI for this; it's not
haxie-based, but a hidden system pref (so it probably can be set from the
command-line as well); TinkerTool does not provide any features that are not
already present in OS X.

What I don't understand is why the text remains vertaically centered but the
icons do not....

Comment 10

13 years ago
(In reply to comment #9)
> What I don't understand is why the text remains vertaically centered but the
> icons do not....

I think it's because we rely on inheritance from NSTextFieldCell to draw the
text, but we draw the image ourselves.
let's see how important this becomes as tiger includes the ability to scale the
ui for ally and higher resolution displays.
Target Milestone: --- → Camino1.0
Target Milestone: Camino1.0 → Camino1.1

Updated

12 years ago
Blocks: 338983

Updated

11 years ago
Assignee: mikepinkerton → d.elliott

Updated

11 years ago
QA Contact: toolbars

Updated

11 years ago
Status: NEW → ASSIGNED

Comment 12

11 years ago
(In reply to comment #11)
> let's see how important this becomes as tiger includes the ability to scale the
> ui for ally and higher resolution displays.

Ha ha, we're totally hosed if the UI resolution is not 1.0, because NSQuickDrawView doesn't support it. (To experiment, run Quartz Debug and hit Command-U.)

Comment 13

11 years ago
I have re-assigned this because it is not an immediate priority and is a good first bug
Assignee: d.elliott → nobody
Status: ASSIGNED → NEW

Updated

11 years ago
No longer blocks: 338983
Target Milestone: Camino1.1 → Camino1.2
Summary: favicons vertically mis-aligned in location bar when system font size changed → UI-scaling / favicons vertically mis-aligned in location bar when system font size changed
*** Bug 351392 has been marked as a duplicate of this bug. ***

Comment 15

11 years ago
I hardly think #351392 is a dupe,as the scope is wider and there is a request for a dialogue in the meantime.

changing summary to reflect these differences
Summary: UI-scaling / favicons vertically mis-aligned in location bar when system font size changed → change application UI font size - provide dialogue in meantime

Comment 16

11 years ago
Reinserting critical search keywords, and removing irrelevent implementation details.  Things like "adding a dialog" should be discussed when the bug is up for fixing, not argued in the summary of a bug.
Summary: change application UI font size - provide dialogue in meantime → UI-scaling / favicons vertically mis-aligned in location bar when changing system font size
Summary: UI-scaling / favicons vertically mis-aligned in location bar when changing system font size → Site icon (favicons) vertically mis-aligned in location bar when changing system font size
Blocks: 351709

Updated

11 years ago
Target Milestone: Camino1.6 → ---
You need to log in before you can comment on or make changes to this bug.