Ability to break/split a thread in threaded mail.

RESOLVED DUPLICATE of bug 36024

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 36024
14 years ago
a year ago

People

(Reporter: David Parrott, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: 

This would mainly be of use to people that use mailing lists. Some of the time 
people start a new thread by replying to an existing post, rather than 
starting a new one. This then shows up in thunderbird as a reply to the 
original, as opposed to being in it's own thread.

The ability to be able to select a message to break/split the thread so that 
the selected message is no longer displayed as part of the original thread, 
but at the top of it's own would be useful.

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
Very good idea!

Comment 2

13 years ago
(In reply to comment #0)

What's even worse than mailing lists is when someone sends you messages with the
same common subject, for instance "FYI" or even "" (no subject). I have about 5
of each in my inbox right now, and none of them are related.

Comment 3

13 years ago
I think converse action of this is important, too. I often want to merge
threads. I submitted bug 295873. I guess that makes it "half-duplicate".

Comment 4

12 years ago
any progress at all on this?
QA Contact: front-end

Updated

11 years ago
Duplicate of this bug: 331342

Comment 6

10 years ago
I have also been bugged (no pun intended) by this for a long time.
I have just uploaded my entire archive of e-mail to GMail, and I have one thread in there with subject "" that spans hundreds of unrelated people, and almost five years, that in fact _is_ unrelated!

If I may make a suggestion:
From my observations, TB threads the mails based on two criteria (remember, this is only MY observations, and may not reflect reality): based on the References or possibly In-Reply-To headers and the Subject. If I am correct, then ideal solution for me would be to create a boolean Preference (in the prefs.js), something like ignore.subject.threading that I could set to false, after which mail would only be threaded if it contains the correct References or possibly In-Reply-To headers.
I swear there's another bug on this.

In the meantime, confirming this enhancement.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Whiteboard: dupeme

Comment 8

10 years ago
Yup, a real old one.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Duplicate of bug: 36024

Comment 9

5 years ago
This request is about splitting, the one marked as the duplicate is about merging threads. It's a similar topic but not a duplicate.
You need to log in before you can comment on or make changes to this bug.