Bookmark Manager does not manage Bookmark Folders

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: Bill Kraengel, Assigned: vlad)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

Re: Firefox 1.0 PR

Bookmark Manager (BM) is supposed to Move (drag) bookmark folders in the
Bookmark menu to where you want and Add & Move (drag) Separators where you want.
It does not! No matter where you add or drag folders and separators, BM does its
own thing and arranges the Bookmark menu in random order. What you see in BM is
NOT what you get in the menu.

Reproducible: Always
Steps to Reproduce:
1. Click Bookmarks on the toolbar
2. Click Manage in the menu
3. Try to manage menu: drag folders, add and drag separators, etc.

Actual Results:  
Unmanaged menu

Expected Results:  
Manage BM menu the way you want

Comment 1

14 years ago
*** Bug 260225 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
*** Bug 260227 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
*** Bug 260228 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
*** Bug 260234 has been marked as a duplicate of this bug. ***
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040917
Firefox/0.10

WFM

moving stuff around is only supposed to happen in the right pane
there are some bugs but it does work

Comment 6

14 years ago
It works ok for me too

Comment 7

14 years ago
Reporter, please ensure that you haven't done any column sorts in the bookmark
manager. With any column based sorting in BM enabled, changes there will not
appear in the Bookmarks Menu. This is intended by the developers to protect Menu
based Sort By Name sorts. Check the columns in BM to see that none of them have
the triangle indicating a sort on that column.  With column sorting off, any
manual changes in BM should be reflected in the Bookmarks Menu. 

marking WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks

Comment 9

9 years ago
I could not add bookmarks or when bookmarking was tried, there were multiples of bookmarks created.  I could neither edit nor delete them; I couldn't even move them.

I had to uninstall 3.0.10 and go back to one of the 2.0.x versions.  So far, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1 is working as it should.

Something must have gone wrong when Firefox went from version 2 to version 3.
You need to log in before you can comment on or make changes to this bug.