Last Comment Bug 260243 - bookmarks deleted after a bad shutdown
: bookmarks deleted after a bad shutdown
Status: RESOLVED DUPLICATE of bug 193749
: dataloss
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: 1.0 Branch
: x86 Windows XP
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 265700 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-18 10:17 PDT by Alex
Modified: 2006-08-27 05:31 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Alex 2004-09-18 10:17:25 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

after a power failure my bookmarks were deleted, and my toolbar customization
was set back

Reproducible: Couldn't Reproduce
Steps to Reproduce:
i do not know, if it happens every time, but
2. start firefox 1 pr
3. and then shutdown the power
Comment 1 Peter van der Woude [:Peter6] 2004-09-18 11:34:26 PDT
Look for

C:\Documents and Settings\USERNAME\Application
Data\Mozilla\Firefox\Profiles\..\bookmarks.html 

and delete it.
than rename the file bookmarks.bak -> bookmarks.html
Comment 2 Vladimir Vukicevic [:vlad] [:vladv] 2004-09-19 20:05:22 PDT
You shouldn't have to copy that stuff over manually; if you can reproduce this,
can you check the size of the bookmarks.html in your profile?  Is it 0, or
greater than 0?  Also check the size of bookmarks.bak.

Firefox should use bookmarks.bak if boomarks.html doesn't exist or its size is 0.
Comment 3 dm 2004-09-28 14:42:32 PDT
It happened several times to me too, basically each time Firefox crashes
seriously (which occurs rather seldom).
I remember to have checked that boomarks.html was existing and of nonzero size
(size was indicated as 1Kb), but it was empty.
Comment 4 Nickolay_Ponomarev 2004-10-22 19:57:16 PDT
*** Bug 265700 has been marked as a duplicate of this bug. ***
Comment 5 OstGote! 2004-12-02 05:51:56 PST

*** This bug has been marked as a duplicate of 193749 ***
Comment 6 Mike Connor [:mconnor] 2006-08-27 05:31:51 PDT
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change

Note You need to log in before you can comment on or make changes to this bug.