On some sites , especially Yahoo mail service, Firefox doesn't handle javascripts correctly

RESOLVED FIXED

Status

Toolkit Graveyard
Error Console
RESOLVED FIXED
13 years ago
a year ago

People

(Reporter: Furkan Duman, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows NT5)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

When I try to empty my bulk my folder in Yahoo mail service, browser cannot
handle javascript code. my bulk mail folder can't empty. Javascript console show
an warning message:
Warning: Non-standard document.all property was used. Use W3C standard
document.getElementById() instead.
Source File:
http://us.js1.yimg.com/us.yimg.com/lib/pim/r/medici/6_16_2/mail/mailcommonlib.js
Line: 13


Reproducible: Always
Steps to Reproduce:
1. Enter Yahoo mail service
2. Click Empty link near the bulk mail folder link
3. Empty dialog box cant show.

Actual Results:  
Empty dialog box can't show.

Expected Results:  
It should show an Empty Bulk mail folder confirmation message.

Comment 1

13 years ago
Furkan, can you update firefox with a recent nightly build from
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-0.9/ and see if
this is working now? It seems to work for me with today's build.
(Reporter)

Comment 2

13 years ago
I tried with daily build but still not working. When I click Empty link on Yahoo
Mail Service, Javascript console displays:
Error: showModalDialog is not defined
Source File: http://us.f407.mail.yahoo.com/ym/login?.rand=427agn2uab129
Line: 209

I tried Linux version of Firefox. Linux version doesn't have this bug!!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

13 years ago
I tried with daily build but still not working. When I click Empty link on Yahoo
Mail Service, Javascript console displays:
Error: showModalDialog is not defined
Source File: http://us.f407.mail.yahoo.com/ym/login?.rand=427agn2uab129
Line: 209

I tried Linux version of Firefox. Linux version doesn't have this bug!!
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 4

13 years ago
Furkan, in tried with seamonkey trunk and firefox 0.10 from today and could not
reproduce the error. I change the ua string to MSIE6 and could reproduce the
showModalDialog error. Use Help->About Firefox and see if you have set your ua
string to MSIE.

I don't have a bulk message folder, but have been sending email to my account,
then deleting it, then emptying the trash. I assume that would give the same error.

Comment 5

13 years ago
there unfortunately has been discussion of adding support for that accursed function

Comment 6

13 years ago
I've got the same problem with the mozilla 1.7.3 browser.  I entered bug number
260959 a few days ago but I haven't heard back from anyone on this.  I don't
have access to a javascript console from mozilla.  Is there another way to
confirm that this problem occurs for the same reason?

Comment 7

13 years ago
I just tested this using Firefox 1.0PR and Mozilla 1.7.3 on WinXP by sending
myself an email, deleting it, then emptying the trash using the [empty] link
next to the Trash folder. It works in both browsers. Marking works for me.
Furkan, if you can reproduce this please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

13 years ago
Still not working for me. Trash Bin and Bulk mail's empty links still show an
error in javascript console.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 9

13 years ago
Furkan, Have you changed your user agent string? what does Help -> About Firefox
give for the User Agent string? If it says "Mozilla/4.0 (compatible; MSIE 5.5;
Windows NT5)", please change it back to "Mozilla/5.0 (Windows; U; Windows NT
5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10" and see if you still get the error.
Are you still getting the showModalDialog error or is it a different error?

(Reporter)

Comment 10

13 years ago
bc. it says that "Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040913 Firefox/0.10". how can i change this information? its interesting
that you are able to display the delete confirmation dialog. i use linux version
of firefox PReview but it works perfectly.

Comment 11

13 years ago
I had the same problem using mozilla 1.7.3 and until just this morning the empty
link didn't work.  It works now, even though I didn't update my browser.  See
bug 260959.  

Comment 12

13 years ago
Try allowing pop-ups and see what happens.  This morning, when the empty link
was working my settings allowed popups.  I realized that this setting had
changed and reset it to prevent popups.  Now I can't empty the bulk or trash
folders using the  emtpy link.

Comment 13

13 years ago
Yes I have tried to access http://www.dvdsoon.com - There are 2 buttons one for
french language and one for english - it does work in (dare I say
it.........no......that other browser) but it will go no further, luckily at the
top there is a tiny bypass link, which I use. Also on
http://www.three.co.uk/hygiene/customerFeedback.omp when you press submit it
also fails to go any further 

For your info 

pehutchinson@msn.com

Comment 14

13 years ago
Yes I have tried to access http://www.dvdsoon.com - There are 2 buttons one for
french language and one for english - it does work in (dare I say
it.........no......that other browser) but it will go no further, luckily at the
top there is a tiny bypass link, which I use. Also on
http://www.three.co.uk/hygiene/customerFeedback.omp when you press submit it
also fails to go any further 

For your info 

pehutchinson@msn.com

Comment 15

13 years ago
Can you check to see if the Yahoo Mail General Preferences (Mail Options >
General Preferences "Warn me about deleting all messages" is turned on?
(Reporter)

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.