saved icon in bookmark doesn't update when the icon of the original page updates

RESOLVED DUPLICATE of bug 240795

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 240795
14 years ago
4 years ago

People

(Reporter: khanban, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

When I visit a page and the icon of that page is saved into the bookmark.html,
any future visit to that page with an updated icon doesn't change the saved icon
in bookmark.

Reproducible: Always
Steps to Reproduce:
1. Visit a page which has an icon 
2. Exit Firefox to save bookmarks.html
3. Change the icon of the page
4. Visit the page again. The icon is the old one.



Expected Results:  
Whenever it refreshes a page, or views it, it should use the icon from the page
instead of the one it has saved into the bookmarks.html. The saved icon should
be used to show the bookmarks, and be updated whenever the page is revisited.

Comment 1

14 years ago
This problem also occurs under Linux.

Comment 2

14 years ago
If i'm not mistake all favicons are called 'favicon.ico' or whatever. Only way
yo fix this bug would be to always reload the favicon on everypage visit. I
think this would look very weird (and ugly) if the favicon flashes for half a
second (while reloading the favicon for lets say the address bar, tabbar and
bookmark toolbar all at the same time. Therefore, I think this bug should be
marked as WONTFIX
(Reporter)

Comment 3

14 years ago
The icon doesn't need to flash. When the browser loads the icon, it simply shows
the new icon instead of the old one. This happens the first time you visit a
page with an icon, when the default icon is replaced by the icon of the page.

The current behaviour is not accepted at all. At the moment, the only way to
remove the old icon is by manually editing the bookmarks.html, which is no good.

As I mentioned before, the browser should always behave like the first time it
visits the page: load the icon on the page (or use the default icon, if there is
not any icon on the page) everytime the page is being visited or refreshed. In
this case it always keeps the most recent icon and shows it in the bookmark
panel. Since we have this behaviour for the first visit and it doesn't create
any problem, why should it create any problem again? It won't.

There is one other thing: in the property window of a bookmark, there is a pane
called "Info". Anothe pane named "Icon" can be added and in that pane the
current icon can be shown. The user can be given radiobutton options such as:
"Keep this icon", "Reload it every visit", and "Use default icon". A "Reset to
default" button can also be provided.

Comment 4

14 years ago
Confirming. 

The current behaviour is that the favicon is set once upon first visit, and then
never set again. This is especially a pain since there are situations where the
wrong icon is associated (and I believe it happens more often than we think; in
my bookmark file there are already dozens of inappropriately associated icons.)
This is also probably why RFE's bug 257791 was filed.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: vladimir → vladimir+bm

Comment 5

14 years ago
Related problem: if you change an URL via bookmark's properties the icon is not
updated either.

Updated

14 years ago
Blocks: 289553

*** This bug has been marked as a duplicate of 240795 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Assignee: vladimir+bm → nobody
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.