Composing Yahoo Mail gives JavaScript errors

RESOLVED DUPLICATE of bug 259935

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 259935
14 years ago
14 years ago

People

(Reporter: Tim Powell, Unassigned)

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Observed with Firefox 1.0PR on Windows XP:

When composing a message in Yahoo mail, I get a JavaScript warning about use of
document.all and then a steady stream of JavaScript errors "event is not
defined" for every key press. 

----
Warning: Non-standard document.all property was used. Use W3C standard
document.getElementById() instead.
Source File:
http://us.js1.yimg.com/us.yimg.com/lib/pim/r/medici/6_16_2/mail/mailcommonlib.js
Line: 13
-----
Error: event is not defined
Source File:
http://us.js1.yimg.com/us.yimg.com/lib/pim/r/medici/6_16_2/mail/mailcommonlib.js
Line: 128
-----

This appears to be caused by the recent change in behavior of "untested"
document.all. I suspect that the code (condensed below) lets this.ie get set to
true:

	d=document;
	this.ns6=(this.dom&&navigator.appName=="Netscape");
	this.ie=(d.all);

This causes problems later:

function ylib_keyevent(evt)
{
	if(oBw.ie||oBw.op) evt=event;

document.all support may also be causing other problems with Yahoo Mail. See bug
260481.
Fixed as of two days ago.

*** This bug has been marked as a duplicate of 259935 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.