Add support for pre-wrap value of white-space

RESOLVED FIXED in mozilla1.9beta4

Status

()

Core
CSS Parsing and Computation
P1
normal
RESOLVED FIXED
13 years ago
7 years ago

People

(Reporter: Hugo Haas, Assigned: roc)

Tracking

(Blocks: 1 bug, {css2, dev-doc-complete})

Trunk
mozilla1.9beta4
css2, dev-doc-complete
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 -
wanted1.9 +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.9

Mozilla supports "white-space: -moz-pre-wrap", which is proprietary, and not the
CSS 2 property "white-space: pre-wrap", which is equivalent.

Could it be added?

Thank you.

Regards,

Hugo

Reproducible: Always
Steps to Reproduce:

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 230555 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Blocks: 230555

Comment 2

13 years ago
See also bug 230555.
No longer blocks: 230555
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: css2
Summary: Please provide support for white-space: pre-wrap → Add support for pre-wrap value of white-space

Updated

13 years ago
Blocks: 206152

Comment 3

13 years ago
s/CSS 2/CSS2.1/

-->Accept, should be as simple as changing all in-source uses from -moz- to
normal use.

Dbaron, should I keep backwards compat somehow with current version, for
websites which used it, similar to how we kept backwards compat with -moz-opacity ?
Assignee: dbaron → 116057
No longer blocks: 206152

Updated

13 years ago
Blocks: 206152
More needs to be done than just renaming.  We first need to make sure it does
what the spec says.
Assignee: 116057 → dbaron
OS: Linux → All
Priority: -- → P1
Hardware: PC → All
*** Bug 330706 has been marked as a duplicate of this bug. ***
Flags: blocking1.9?
Depends on: 191699
Flags: blocking1.9? → blocking1.9-
Whiteboard: [wanted-1.9]
QA Contact: ian → style-system
I think we'll be looking good for this when I'm done with bug 393096
Depends on: 393096
Blocks: 410460
I think we should do this now. Our white-space:-moz-pre-wrap handling has improved a lot and is now very good IMHO.
Depends on: 411792
Created attachment 296444 [details] [diff] [review]
fix?

This should do it.

We could give -moz-pre-wrap its own value so that getComputedStyle and readers of style.whiteSpace can still return "-moz-pre-wrap", but I don't think that should be necessary.

There are a lot of uses of -moz-pre-wrap in stylesheets in our tree, which could be replaced in a separate patch.

I did some testing and found bug 411792, which should be fixed before we land this.
Assignee: dbaron → roc
Status: NEW → ASSIGNED
Attachment #296444 - Flags: superreview?(dbaron)
Attachment #296444 - Flags: review?(dbaron)
Flags: wanted1.9+
Whiteboard: [wanted-1.9]
Comment on attachment 296444 [details] [diff] [review]
fix?

r+sr=dbaron.

I tend to think you should just remove -moz-pre-wrap (from nsCSSProps.cpp and nsCSSKeywordList.h).

Could you add pre-wrap to layout/style/test/property-database.js too ?
Attachment #296444 - Flags: superreview?(dbaron)
Attachment #296444 - Flags: superreview+
Attachment #296444 - Flags: review?(dbaron)
Attachment #296444 - Flags: review+
> Could you add pre-wrap to layout/style/test/property-database.js too ?

OK

> I tend to think you should just remove -moz-pre-wrap (from nsCSSProps.cpp and
> nsCSSKeywordList.h).

We use it all over the place in our tree. I could do a big search-and-replace, but extensions may also use it, not to mention actual Web sites. Can we not do this in 1.9? I think it's polite to have a transition period with both are supported.
OK, fine to keep -moz-pre-wrap for 1.9 given how close to release we are, but file a bug on removing it afterwards.
Comment on attachment 296444 [details] [diff] [review]
fix?

For a long time we've supported CSS "white-space:-moz-pre-wrap" but it was too buggy to officially support it as "white-space:pre-wrap". Now, thanks to all the text work in 1.9, we think it's ready to enable via "pre-wrap"; that's all this patch does.

The patch looks big but it's actually quite simple. The risk is that Web sites using "pre-wrap" might be broken by this change.
Attachment #296444 - Flags: approval1.9?

Comment 13

10 years ago
Comment on attachment 296444 [details] [diff] [review]
fix?

Thnx for the backgroun Roc
Attachment #296444 - Flags: approval1.9? → approval1.9+
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago10 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
filed bug 418543 on removing -moz-pre-wrap.

Updated

10 years ago
Keywords: dev-doc-needed
Blocks: 418543
Target Milestone: --- → mozilla1.9beta4
This is already documented, marking as doc complete.
Keywords: dev-doc-needed → dev-doc-complete
Depends on: 435177
You need to log in before you can comment on or make changes to this bug.