firefox (0.10) does not abide by gnome theme/skin settings on menu backgrounds

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: zero79, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

firefox appears to follow the gnome theme and skin settings in all parts of the
interface except for in background images in menus.  see screenshot at

http://zero79.dyndns.us:8000/pics/firefox_error.jpg

to see that there is no skin behind the bookmarks menu (the background is just
painted gray), but the rest of the interface is skinned (grey metal Panther
gnome theme).

Reproducible: Always
Steps to Reproduce:
1.  install the panther theme for gnome.
2.  start up firefox 0.10 and install the qute theme.
3.  restart firefox
4.  observe skinning disparity in menus vs. the rest of the interface.

Actual Results:  
it's always been like this from what i can tell (at least back to firefox 0.8,
and i'm sure before that also)

Expected Results:  
skin the menus according to the gnome theme as well as the rest of the interface.

Comment 1

14 years ago
*** Bug 267015 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
Should firefox really follow gnome theme settings? I am using windows at work
and GNU/linux at home, and I was actually disappointed with the fact, that the
same version of browser (1.0), using the same (default) theme, looks different
on each OS. One of the good features in mozilla is the same look&feel (to the
most possible extent) at all OS. So, according to my opinion, the firefox should
do quite the opposite - it should, at least for default theme, not follow gnome
settings at all.
Actually, Mozilla's Classic theme does derive a lot of look+feel from the OS
theme, whether its Windows or GNOME.  (In case it isn't obvious, we use the OS
theme look+feel on Windows as well).

There's two schools of thought on this of course, but we've always worked
towards making the app feel and act like a native app.  Making it NOT fit in
really doesn't help, it tends to end up looking out of place and feeling "wrong"

</offtopic>

reporter, if you try a trunk build or wait for 1.1 this should be vastly improved.
(Reporter)

Comment 4

14 years ago
In response to the comments in #2, I don't think that adhering to native
skinning standards significantly complicates the use experience on multiple
platforms.  Ultimately, the icons are the in the same locations and have the
same look.  However, when menu items in different locations such as "tools ->
options" on windows vs "edit -> preferences" on other platforms, this does
complicate things.  I don't know how many times I have tried to go to tools ->
options, but I suppose that that may have been ingrained by using ie on windows
for a significant amount of time (its the only browser i can use at work).  it
would be a wholey different matter if i could completely abondon ie i think. 
btw, is there a config setting that changes the location of the "preferences"
menu on windows firefox?

anyway, i too agree with #3 that apps should conform to the native theme.  if
firefox didn't for the most part feel like gnome, i would be using epiphany.  i
just feel a lot more comfortable in gnome than icewm (even though icewm performs
a lot better), just for the fact that most apps that i will use in gnome will
feel the same.  but icewm apps use all kinds of toolsets that just don't look
like they go together, and menu items are in varying locations.
As far as I've seen there are no Firefox/Thunderbird (1.0) default themes
available which correctly adhere to Gnome/KDE theming. I've Gtk-Qt style set up,
and all Gtk apps render correctly in Qt-manner, but not Firefox (nor Thunderbird).

Comment 6

14 years ago
This seems to be fixed in the latest Firefox nightly builds
resolving WORKSFORME, trunk is vastly better than 1.0.x, so 1.1 will be much
better, when its done.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.