dom.popup_maximum blocks popups

RESOLVED DUPLICATE of bug 260264

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 260264
14 years ago
12 years ago

People

(Reporter: Martin Sch, Assigned: Blake Ross)

Tracking

(Blocks: 1 bug)

1.0 Branch
Other
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
There is a site where a company shows product details in a popup when you click
on a javascript: link. After looking for some products, popups where blocked and
it did not help to allow popups for that site. So I switched off popup blocking
completely, but that did not help.

At least, I found the setting dom.popup_maximum which was set to 20. This
settings seems to block popups if there have been more than 20, even if popup
blocking is disabled. This is a bug. This should only be active if popup
blocking is active. 

And the value should be set to a default of 1000 as long as this setting is not
visible in the UI.
(Reporter)

Updated

14 years ago
No longer blocks: 176958
Depends on: 176958
(Reporter)

Comment 1

14 years ago
I was re-thinking about this and it is correct that popup_maximum is active if
popup blocking is disabled. If popup blocking where active, this maximum popup
limit was not needed.

But popup_maximum should not be active if the domain is in the white list.
adding the url of the site does help others to test it for themselves

Updated

14 years ago
Blocks: 176958
No longer depends on: 176958
(Reporter)

Comment 3

14 years ago
I'm aware that a URL would be of use, but the one I had the problems is for
members only.

Comment 4

14 years ago
System and build information, please. Also see bug 260264.
(Reporter)

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 260264 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.