Print Preview results in crash with this page

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: ffolkes, Assigned: bugzilla)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

When I try to print this page, with any driver, on any computer I have, it
crashes Firefox. I needed to print it, so I opened IE, and it acted oddly as
well - it printed a blank page.

I have no idea what's wrong with that page, but something is causing Firefox to
crash.

Reproducible: Always
Steps to Reproduce:
1. Go to that URL. (http://southernfood.about.com/od/bananabread/r/bl30322l.htm)
2. File -> Print Preview -> Ok.
3. Crash.

Actual Results:  
Crashed.

Expected Results:  
Not crashed. ;)

"Exception in Firefox.exe"

Updated

14 years ago
Keywords: crash

Comment 1

14 years ago
Crashed for me as well with 20040924 branch build, did not crash on suite trunk.

Incident ID: TB980794H

Comment 2

14 years ago
I can confirm this.
Just sent a crash-Report too (Gecko/20050317 - subject:
https://bugzilla.mozilla.org/show_bug.cgi?id=261502).

Btw - how do I get the ID of my submitted crash-report.

Comment 3

14 years ago
Go to the components directory, find the talkback.exe if you are on windows and
launch it.

Comment 4

14 years ago
wfm with current trunk build Mozilla and FF Deer Park Alpha 1 (on Win2k).

Comment 5

14 years ago
wfm with current trunk, problem exists in 1.0.x branch, anyway resolving as wfm
since i don't know which bug to dupe to exactly :) (maybe it's the ign.com
crasher, Stacktrace here is:
0x00000000
nsIView::Destroy 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/view/src/nsView.cpp,
line 251]
nsSubDocumentFrame::Destroy 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/document/src/nsFrameFrame.cpp,
line 568]
nsLineBox::DeleteLineList 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsLineBox.cpp,
line 302]
nsFrameList::DestroyFrames 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/base/src/nsFrameList.cpp,
line 129])
Anyway this won't get fixed in the 1.0.x branch for sure.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 6

13 years ago
*** Bug 305545 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
*** Bug 289392 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.