If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Reproducible crash if attempting to print http://www.snopes.com/military/lighthse.htm

RESOLVED DUPLICATE of bug 261502

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 261502
12 years ago
12 years ago

People

(Reporter: Mozilla.20.TEN, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Firefox terminates with the following error when invoking Ctrl-P on
http://www.snopes.com/military/lighthse.htm

firefox/run-mozilla.sh: line 451:  1725 Segmentation fault      "$prog" ${1+"$@"}

Given that the page contains advertising banners that are likely to change over
time, it may not remain reproducible forever - but currently it is (with Firefox
running under fvwm2 and attempting to print through lpr -Plp handled by CUPS).

Reproducible: Always

Steps to Reproduce:
1. http://www.snopes.com/military/lighthse.htm
2. Ctrl-P
3. Click [Print]

Actual Results:  
Crash (segfault)

Expected Results:  
Should have printed the page.

SuSE Linux 8.2 running only fvwm2, with lpr handled by CUPS, on an ancient AMD
K6-2/400 having just 128 MB of RAM.

about:buildconfig

Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 3.3.2 20031022 (Red Hat Linux 3.3.2-1) 	-Wall -W -Wno-unused
-Wpointer-arith -Wcast-align -Wno-long-long -pedantic -pthread -pipe
c++ 	gcc version 3.3.2 20031022 (Red Hat Linux 3.3.2-1) 	-fno-rtti
-fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor
-Wno-long-long -pedantic -fshort-wchar -pthread -pipe -I/usr/X11R6/include

Configure arguments
--disable-ldap --disable-mailnews
--enable-extensions=cookie,xml-rpc,xmlextras,pref,transformiix,universalchardet,webservices,inspector,gnomevfs,negotiateauth
--enable-crypto --disable-composer --enable-single-profile
--disable-profilesharing --disable-debug '--enable-optimize=-Os -freorder-blocks
-fno-reorder-functions -gstabs+' --disable-tests --enable-official-branding
--enable-default-toolkit=gtk2 --enable-xft --disable-freetype2 --enable-static
--disable-shared
(Reporter)

Comment 1

12 years ago
Interestingly, Firefox in the above configuration is also "crashable" by
attempting to print the URL reported by
https://bugzilla.mozilla.org/show_bug.cgi?id=302911, i.e.
http://www.geocaching.com/seek/cache_details.aspx?guid=224b9d1a-82a7-429f-adb3-89c8fd6652e5
- which suggests that while not duplicates, both bugs may be closely related.

Comment 2

12 years ago
Can you provide a talkback ID for the crash? http://kb.mozillazine.org/Talkback
(Reporter)

Comment 3

12 years ago
> Can you provide a talkback ID for the crash?

I don't think there is such a thing in my ~/firefox/components of this Linux
build ;-/ Of course I could install something different, but then who knows
whether it would still crash...

However what I have already managed to do is to try and reproduce it in quite a
different version & environment, on Windows 98 (US first edition) rather than
Linux (running on similar -ancient- hardware):
There, Firefox always crashes when attempting to print the URL reported in this
bug (but NOT on the one from 302911) as well - not "always in the same place",
but at least "always" and also "always with a page fault":

Firefox 0.9
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

FIREFOX caused an invalid page fault in
module <unknown> at 0000:00000013.
Registers:
EAX=02cd4dbc CS=017f EIP=00000013 EFLGS=00010a82
EBX=02ccc840 SS=0187 ESP=00c8ea28 EBP=00c8ea44
ECX=5049cd02 DS=0187 ESI=02ccfaa0 FS=3c8f
EDX=00c8ea2c ES=0187 EDI=027c3364 GS=0000
Bytes at CS:EIP:
00 54 ff 00 f0 08 80 00 f0 6f ef 00 f0 00 00 00 
Stack dump:
00000187 005dbfcc 00000001 00584bfe 00000000 027c3364 02ccc840 00c8ea5c 00ebeafd
 027c3364 02cd4950 027c317c 00980fe0 00c8eab4 006b9e2a 027c3364 

FIREFOX caused an invalid page fault in
module XPCOM.DLL at 017f:602ff99b.
Registers:
EAX=0286665c CS=017f EIP=602ff99b EFLGS=00010297
EBX=0285a220 SS=0187 ESP=00c8e988 EBP=ffffe460
ECX=02862570 DS=0187 ESI=02858550 FS=3227
EDX=00c8ea2c ES=0187 EDI=05602c6c GS=0000
Bytes at CS:EIP:
1b 1c 1d 1e 1f 20 21 22 23 24 25 26 27 28 29 2a 
Stack dump:
05602c6c 02858550 ffffe460 00c8e9a8 0285a220 00c8ea2c 02862570 0286665c 05602c6c
 02858550 ffffe460 00c8e9c8 0285a220 00c8ea2c 02862570 0286665c

Comment 4

12 years ago
Install talkback; get a talkback ID for the crash. 
(Reporter)

Comment 5

12 years ago
Uh-oh ;-/ "Something weird, and it don't look good..."

Tried the shiny new laptop next door (Firefox 1.0.4 on WinXP SP 2 with all
current fixes), and it crashes when trying to print the URL reported in THIS bug
as well.
Actually then it also even wants to send a ton of debug memory dumps to Microsoft.

Will need to get some Talkback-enabled builds next time I'm near a broadband
line, but given these results I am sure others will be able to confirm this bug
shortly.

Comment 6

12 years ago
maybe at least try installing firefox 1.0.6 first and then try to reproduce

Comment 7

12 years ago
We really can't do anything until we know why it's crashing. Please reinstall
Firefox with talkback enabled, or install it as an extension from here:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2005-08-22-06-aviary1.0.1/windows-xpi/talkback.xpi
(Reporter)

Comment 8

12 years ago
> at least try installing firefox 1.0.6 first and then try to reproduce

> We really can't do anything until we know why it's crashing.

Unfortunately the Talkback server itself (below) was down for maintenance as well.

"My" Talkback Incident ID is 8653634; someone else had already come up with
8615670 also referring to this bug 305545:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=8653634
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=8615670

Comment 9

12 years ago
Stacktrace (shortened) with 1.7 branch from Print Preview (i was not able to get
a stacktrace with printing):
nsIView::Destroy() line 250 + 28 bytes
nsFrame::Destroy(nsFrame * const 0x03c4e42c, nsIPresContext * 0x03a09448) line 647
nsSubDocumentFrame::Destroy(nsSubDocumentFrame * const 0x03c4e42c,
nsIPresContext * 0x03a09448) line 569
nsLineBox::DeleteLineList(nsIPresContext * 0x03a09448, nsLineList & {...}) line 303
nsBlockFrame::Destroy(nsBlockFrame * const 0x03c4e208, nsIPresContext *
0x03a09448) line 301 + 16 bytes
nsFrameList::DestroyFrames(nsIPresContext * 0x03a09448) line 130
nsContainerFrame::Destroy(nsContainerFrame * const 0x03c4e194, nsIPresContext *
0x03a09448) line 166
nsFrameList::DestroyFrames(nsIPresContext * 0x03a09448) line 130
nsContainerFrame::Destroy(nsContainerFrame * const 0x03c4e068, nsIPresContext *
0x03a09448) line 166
nsFrameList::DestroyFrames(nsIPresContext * 0x03a09448) line 130
nsContainerFrame::Destroy(nsContainerFrame * const 0x03c4dfc0, nsIPresContext *
0x03a09448) line 166
nsFrameList::DestroyFrames(nsIPresContext * 0x03a09448) line 130
nsContainerFrame::Destroy(nsContainerFrame * const 0x03c4def8, nsIPresContext *
0x03a09448) line 166
nsTableFrame::Destroy(nsTableFrame * const 0x03c4def8, nsIPresContext *
0x03a09448) line 311
nsFrameList::DestroyFrames(nsIPresContext * 0x03a09448) line 130
nsContainerFrame::Destroy(nsContainerFrame * const 0x03c4dd30, nsIPresContext *
0x03a09448) line 166
nsTableOuterFrame::Destroy(nsTableOuterFrame * const 0x03c4dd30, nsIPresContext
* 0x03a09448) line 83
nsFrameList::DestroyFrames(nsIPresContext * 0x03a09448) line 130
nsBlockFrame::Destroy(nsBlockFrame * const 0x03bf770c, nsIPresContext *
0x03a09448) line 301
nsLineBox::DeleteLineList(nsIPresContext * 0x03a09448, nsLineList & {...}) line 303
nsBlockFrame::Destroy(nsBlockFrame * const 0x03bf7688, nsIPresContext *
0x03a09448) line 301 + 16 bytes
nsLineBox::DeleteLineList(nsIPresContext * 0x03a09448, nsLineList & {...}) line 303
nsBlockFrame::Destroy(nsBlockFrame * const 0x03bf80dc, nsIPresContext *
0x03a09448) line 301 + 16 bytes
nsFrameList::DestroyFrames(nsIPresContext * 0x03a09448) line 130
nsContainerFrame::Destroy(nsContainerFrame * const 0x03bf807c, nsIPresContext *
0x03a09448) line 166
nsFrameList::DestroyFrames(nsIPresContext * 0x03a09448) line 130
nsContainerFrame::Destroy(nsContainerFrame * const 0x03bf8024, nsIPresContext *
0x03a09448) line 166
nsFrameList::DestroyFrames(nsIPresContext * 0x03a09448) line 130
nsContainerFrame::Destroy(nsContainerFrame * const 0x03bf7790, nsIPresContext *
0x03a09448) line 166
nsFrameList::DestroyFrames(nsIPresContext * 0x03a09448) line 130
nsContainerFrame::Destroy(nsContainerFrame * const 0x03bf817c, nsIPresContext *
0x03a09448) line 166
nsTableFrame::Destroy(nsTableFrame * const 0x03bf817c, nsIPresContext *
0x03a09448) line 311
nsFrameList::DestroyFrames(nsIPresContext * 0x03a09448) line 130
nsContainerFrame::Destroy(nsContainerFrame * const 0x03bf8130, nsIPresContext *
0x03a09448) line 166
nsTableOuterFrame::Destroy(nsTableOuterFrame * const 0x03bf8130, nsIPresContext
* 0x03a09448) line 83
nsLineBox::DeleteLineList(nsIPresContext * 0x03a09448, nsLineList & {...}) line 303
nsBlockFrame::Destroy(nsBlockFrame * const 0x03bf8338, nsIPresContext *
0x03a09448) line 301 + 16 bytes
nsFrameList::DestroyFrames(nsIPresContext * 0x03a09448) line 130
nsContainerFrame::Destroy(nsContainerFrame * const 0x03bf82d8, nsIPresContext *
0x03a09448) line 166
nsFrameList::DestroyFrames(nsIPresContext * 0x03a09448) line 130
duping, it's the same 0xddddddd5 crash

*** This bug has been marked as a duplicate of 261502 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.