The default bug view has changed. See this FAQ.

Can't completely disable the new "Install Missing Plugins" infobar

RESOLVED FIXED

Status

Toolkit Graveyard
Plugin Finder Service
--
enhancement
RESOLVED FIXED
13 years ago
3 years ago

People

(Reporter: Daniel Cordeiro, Assigned: db48x)

Tracking

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

In 1.0PR there is a new toolbar that appears on top of the page when a plugin
are required.

But when one doesn't want to install any plugins, this is really annoying.

Firefox should have a way to disable this toolbar.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
*** Bug 262448 has been marked as a duplicate of this bug. ***
->NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

13 years ago
There is a way to disable it.

about:config -> plugin.default_plugin_disabled -> false, then restart

Should we change this to bug's focus to getting a button/menu/other option on
the toolbar to disable? Otherwise this is INVALID.
(Reporter)

Comment 4

13 years ago
I think that it is only a "work around". The toolbar and the de default plugin
are two distinct things.

I like to see that image at the place where the object (that requires plugin) is.
But I don't like to see the toolbar using the space of web page. It's is very
intrusive, in my opinion.

If one doesn't want to install any plugin, this is fine. But when one doesn't
want to install one specific plugin, this is a bad solution.

Comment 5

13 years ago
ah gotcha, sorry about that.

Updated

13 years ago
Assignee: bugs → doronr
Component: Toolbars → Plugin Finder Service
QA Contact: bugzilla → firefox.plugin.finder

Comment 6

13 years ago
*** Bug 261919 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
Firefox shows "install missing plugins" bar, shows apple quicktime 6.5.1 as
being available, supposedly installs plugin, but "install missing plugins" bar
does not go away and the cycle is repeated. This is on a page with sound when
page loads. Sound does not play. The bar can be closed, but reappears when page
is reloaded.

Comment 8

13 years ago
*** Bug 268574 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
*** Bug 267942 has been marked as a duplicate of this bug. ***

Comment 10

13 years ago
See also bug 268936, allow user to disable "additional plugins required bar" for
given plugin.
*** Bug 270127 has been marked as a duplicate of this bug. ***

Comment 12

13 years ago
I'd like to never install flash and to have Firefox always ignore content
from this plugin.

If I do not install the flash player, I get a requester asking if I want to
download the .swf file.

Øyvind
targetting 1.1 with this.  There will be a hidden pref that disables showing the
infobar for missing plugins.
Blocks: 272704
Status: NEW → ASSIGNED
Summary: Can't disable the new "Install Missing Plugins" toolbar → Can't disable the new "Install Missing Plugins" infobar
Target Milestone: --- → Firefox1.1

Comment 14

13 years ago
(In reply to comment #13)
> targetting 1.1 with this.  There will be a hidden pref that disables showing the
> infobar for missing plugins.

Why a hidden pref? Many people _really_ don't want Flash or any other such
annoying and/or non-free plugins to be installed. It'd be a shame that it is
encouraged with a big yellow bar and other notifications to install Flash et cetera.

Disabling should handled the same way like with popup windows. E.g. "Additional
plugins are required to display all the media on this page. Click here for
options...", with the options being e.g.:
- Install missing plugins
- Edit software installation settings (isn't plugin installation about software
installation, too?)
- Don't show this message when additional plugins are required

Makes sense?
clicking on the infobar is unacceptable since its not accessible.

Adding any UI in firefox is hard and requires special approval, feel free to
bring it up with ben goodger.

Comment 16

13 years ago
I would highly recommend the same method that is used to disable further
notifications about blocking pop-ups.
(Reporter)

Comment 17

13 years ago
I don't get it.
Why infobar is not accessible?

I agree with comment #14. The infobar should act like the "block popup" bar. It
will make the firefox UI more consistent.

Comment 18

12 years ago
Comment #15: I e-mailed Ben Goodger about this something like two weeks ago, but
he hasn't responded. Is there some other way you would propose to bring this to
his attention?
Hardware: PC → All
Summary: Can't disable the new "Install Missing Plugins" infobar → Can't completely disable the new "Install Missing Plugins" infobar
Blocks: 268936
The infobar is unaccessible to keyboards - only buttons on the infobar are.

Anyways, dropping this for now unless I get time to work on it.
Status: ASSIGNED → NEW
Target Milestone: Firefox1.1 → ---

Comment 20

12 years ago
Does the plug-in infobar have an ID so it could be turned off via a
#xyz { display: none !important } rule in userChrome.css?
(In reply to comment #20)
> Does the plug-in infobar have an ID so it could be turned off via a
> #xyz { display: none !important } rule in userChrome.css?

You would disable the popup blocked and XPI installation one, as they use the
same UI element.

Comment 22

12 years ago
(In reply to comment #21)
> (In reply to comment #20)
> > Does the plug-in infobar have an ID so it could be turned off via a
> > #xyz { display: none !important } rule in userChrome.css?
> 
> You would disable the popup blocked and XPI installation one, as they use the
> same UI element.

I wouldn't mind that as a temporary workaround since I have the "popup blocked"
bar turned off anyway and I don't plan on installing any XPIs any time soon.
After some more searching through the JARs, I have finally come up with the
following CSS snippet which, with the limitations mentioned above, works
for me (and is less annoying than clicking away the infobar on each page that
uses Flash):

browsermessage {
  display: none !important;
}

Comment 23

12 years ago
I tried the setting in comment #3 and it made the info bar go away, but instead
when I visit a page with flash on it, I get a pop-up asking whether to download
the flash plugin, which is even worse!  I'd be happy if there was a way to just
turn that infobar off; it's nice if later there's fine grained tracking about
which specific plugins are refused, but that's less of a big deal.
Created attachment 203720 [details] [diff] [review]
patch

Kind of hard to test, given that plugin finder is broken at the moment, but this should work. It provides a pref to never show the browser message bar while still allowing you to click the "missing plugin" icon on the page itself.
Wouldn't it be better to make it a disabling preference?  So if the pref is not found (which is unlikely) we retain our default behavior (since most people will want the infobar).
*** Bug 330182 has been marked as a duplicate of this bug. ***

Comment 27

11 years ago
How would a user create a null plugin for the unwanted service, and install that null plugin?
(Assignee)

Comment 28

10 years ago
Created attachment 265800 [details] [diff] [review]
patch

This infobar message was particularly annoying today, so I ended up writing this to disable it, not realizing that Gavin had already written on. Anyway, one of these patches should be checked in regardless of whether there's a ui for the pref.

I prefer my implementation, because I think the code is a bit cleaner. They have the same effect though, so it doesn't really matter much.
Attachment #265800 - Flags: review?(neil)
My patch probably no longer applies (it was written before we had the new notification bar, I think). I think using a <preference> element for this is overkill.
(Assignee)

Comment 30

10 years ago
(In reply to comment #29)
> My patch probably no longer applies (it was written before we had the new
> notification bar, I think). I think using a <preference> element for this is
> overkill.
> 

It looked like it would apply, though I didn't try it. One thing I noticed was that your patch makes it return from newMissingPlugin() before setting the missingPlugins property on the tab, though I don't know how important that is.

You're probably right about the <preference> element. It retrieves the value of the pref in it's constructor rather than only when it's needed. I guess it's a trade off between once per window versus once per page load.

Comment 31

10 years ago
Comment on attachment 265800 [details] [diff] [review]
patch

I'm not a browser peer but I agree with Gavin.
Attachment #265800 - Flags: review?(neil)

Comment 32

10 years ago
(In reply to comment #28)

Daniel: I manually applied your patch to firefox 2.0.0.6 and it is working.
 
Thank you very much.
(Assignee)

Comment 33

10 years ago
Created attachment 283197 [details] [diff] [review]
261655-3.diff

Thanks. I had forgotten that this patch hadn't made it in to the tree. This version doesn't use a <preference> element.
Assignee: doronr → db48x
Attachment #203720 - Attachment is obsolete: true
Attachment #265800 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #283197 - Flags: review?(mconnor)

Updated

10 years ago
Attachment #283197 - Flags: review?(mconnor)
Attachment #283197 - Flags: review+
Attachment #283197 - Flags: approval1.9+
(Assignee)

Comment 34

10 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.