.cvsignore contains itself in two directories in xpinstall

RESOLVED FIXED

Status

Core Graveyard
Installer: XPInstall Engine
RESOLVED FIXED
13 years ago
2 years ago

People

(Reporter: gerv, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
In the directories:
mozilla/xpinstall/packager/windows
mozilla/xpinstall/wizard/windows/setuprsc
the .cvsignore file includes itself.

This means that any attempt to cvs import a checked-out copy of NSS into another
CVS tree excludes the .cvsignore file, and so it won't be present (and therefore
you'll get unnecessary ?s) in a tree pulled from the new repository.

This is due to cvs import -I ! still respecting .cvsignore - see the notes about
the -I option here:
https://www.cvshome.org/docs/manual/cvs-1.11.17/cvs_18.html#SEC178

So, ".cvsignore" should be removed from .cvsignore in these two directories.

Gerv
Fixed on trunk. Thanks for catching this Gerv.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

13 years ago
What a fast response!

dveditz: if you are feeling particularly keen, I also filed bug 261794, bug
261796 and bug 261797 for the same problem in different bits of the tree. Of
course, I don't know if it's possible to know for certain what the correct fix
is without consulting the module owner... is it pretty obvious that .cvsignore
needs editing, or are there other possible resolutions?

Gerv
The fast response was in part because there was no process overhead getting it
fixed. I think the module owners or a cvs/build uber-owner needs to do these.

bug 261796 is only a problem on the aviary (and 1.7) branch... do you need these
fixes on the branches?
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.