[FEATURE] Please Implement SVG (Scalable Vector Graphics)

RESOLVED FIXED

Status

()

Core
SVG
P3
enhancement
RESOLVED FIXED
18 years ago
11 years ago

People

(Reporter: Lars Brubaker, Assigned: Dean Jackson)

Tracking

Trunk
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
We need a browser that has Scalable Vector Graphics and Mozilla is the one that 
it must be.  It's up to us and it has to be in sometime after 5.0 gets out.

We need a place to say how important this is.  If we don't have a bug we can't 
vote for it.

If anyone looking at this bug doesn't know what it is check it out at
http://www.w3.org/Graphics/SVG/
(Reporter)

Updated

18 years ago
Summary: Please Implement SVG (Scalable Vector Graphics) → [FEATURE] Please Implement SVG (Scalable Vector Graphics)

Comment 1

18 years ago
I filed a bug on this a while back - it got pushed to "remind" which is sorta 
odd. (http://bugzilla.mozilla.org/show_bug.cgi?id=17679)
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 2

18 years ago
*** Bug 17679 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
Some comments posted by Jeremy Lea on n.p.m.layout.
(See also screenshot at: http://people.freebsd.org/~reg/mozilla-svg-lion.jpg)

Jeremy Lea wrote:
> 
> Hi,
> 
> On Fri, Feb 18, 2000 at 03:05:54PM +1100, Dean Jackson wrote:
> > If you are interested in helping out in any way (including
> > writing code, QA, documentation, etc) please let me know.
> > I've volunteered to organize the project.
> 
> I've put my patches on http://people.freebsd.org/~reg/ (at the bottom of
> the page).  They should give you a head start...
> 
> My apologies to everyone for being so quite about my efforts to get this
> going, but Real Life(tm) has really been taking it's toll on me at the
> moment.
> 
> The patches are up to date, but there are some things which are broken
> in them.  I just don't have the time to keep track of Mozilla's ever
> changing API's.
> 
> Regards,
>  -Jeremy

Comment 4

17 years ago
Is this a [meta] bug of some sort?

Comment 5

17 years ago
FYI, see bug 80142 -- a new implementation of SVG
for mozilla has popped up and is looking both
functional and pretty.

http://www.croczilla.com/svg/

Bug 80142 is concentrating on getting this new code,
which currently exists as a set of floating zips and
patches, into CVS.

(And that bug alone has 25 votes to go with the 34 on
this bug... perhaps it could do with some more, hint hint)
Depends on: 80142

Comment 6

16 years ago
Partial SVG support is now checked into the trunk, and being actively worked on.
We have a SVG component in bugzilla for bugs that's used, and we even have our
own little IRC channel: #svg, at irc.mozilla.org

It's not on in the default builds though.  I'd say this is fixed, we're finally
making good progress!
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 7

16 years ago
Is there a bug covering general SVG support/tracking progress? I guess the SVG
implementation is nowhere near complete so perhaps it's not worth doing it, but...

In particular I tried the W3C SVG test at http://www.w3.org/Graphics/SVG/Test
and only found one or two of the test files that rendered at all on the
2001121303 build, and those were incorrect... ;) I considered filing a bug re.
that particular test but then figured there probably was one even though I
couldn't find it...

(Here is one of those that renders:
http://www.w3.org/Graphics/SVG/Test/20011026/style-selector-BE-01-ps.html)

Comment 8

16 years ago
As I said, it's *not* yet enabled on trunk builds / nightlies, unless you build
by yourself. That's why it didn't work for you.  :-)

You don't need a tracking bug for this, because, again, as I said: there's a
component for which you can query all reported bugs if you are interested. Go to
bugzilla's query page and choose:  Product: Browser,  Component:  SVG
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.