Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 262326 - First Radio button not selected by default in initial Migration Wizard.
: First Radio button not selected by default in initial Migration Wizard.
: regression
Product: Firefox
Classification: Client Software
Component: Migration (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 15
Assigned To: Nobody; OK to take it and work on it
: Matthew N. [:MattN] (PM me if I'm slow responding)
Depends on: 748569
  Show dependency treegraph
Reported: 2004-09-30 11:28 PDT by Tracy Walker [:tracy]
Modified: 2012-06-15 00:15 PDT (History)
7 users (show)
cbeard: blocking1.8b5-
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

Screen shot. (9.78 KB, image/png)
2004-10-06 08:54 PDT, Kenny Lee
no flags Details

Description Tracy Walker [:tracy] 2004-09-30 11:28:51 PDT
Seen on FF Windows branch build 2004-09-30-08-0.9

-Delete Firefox profile dir
-Launch build

tested results:
The resulting Import Wizard has four items with Radio buttons as follows:

o MS IE (outlined but the radio button is not selected)
o NS 6,7 or Moz 1.x
o NS 4.x
o Dont import anything

expected results:
the radio button for the first item should be selected by default.

-clicking next without actually selecting any item (leaving the first item, in
this case IE, outlined but not selected), imports the settings for IE.
-Calling File | Import from the app doesn't exhibit this issue.
-I'm not seeing this on Mac, but I only have a Mozilla profile to migrate there.
Comment 1 Kenny Lee 2004-10-06 08:54:44 PDT
Created attachment 161270 [details]
Screen shot.
Comment 2 Tracy Walker [:tracy] 2004-10-06 09:25:16 PDT
Kenny,  I think you meant that attachment for bug 262304. :-)
Comment 3 Jon Stritar 2005-06-17 21:04:20 PDT
Is this still a bug? I just tried it out on Deer Park Alpha 1 and it works for
me (with those exact 4 selections). I couldn't test it on the nightlies because
for some reason the Import Wizard wouldn't automatically load on them.
Comment 4 Tracy Walker [:tracy] 2005-06-18 19:06:35 PDT
Yes, this is still a bug.  currently bug 297915 would be blocking testing this bug.

Note: this is not about Import, it is about Migration.
Comment 5 Tracy Walker [:tracy] 2005-06-27 06:30:18 PDT
I have been seeing this on 1.0.5 on Windows as well.  

I discovered the following makes this reliably reproducable:
-set Mozilla Suite as the default browser under Edit | Preferences
-Delete Firefox profile dir
-Launch Firefox build

If IE or Firefox were previously set as the default browser, the initial
migration wizard has the first radio button (IE) selected by default.  If
Mozilla suite was set as default browser, the radio button for Moz/Ns is selected.

I have only IE, Moz1.7.8 and Fx 1.0.5 installed; no other browsers present.
Comment 6 Chris Beard 2005-08-25 14:47:47 PDT
not blocking, if verified to still exist and low-risk patch appears within the
next week we'll take it
Comment 7 Tracy Walker [:tracy] 2005-08-25 19:17:54 PDT
This does still exist on Windows.  It's also affecting Mac. Safari is the first
in the Migration list and it is not selected by default.  
Comment 8 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-04-25 08:25:35 PDT
To be fixed in bug 748569.
Comment 9 Paul Silaghi, QA [:pauly] 2012-06-15 00:06:00 PDT
The default browser is automatically selected on initial Migration Wizard on FF 14b7 on Win 7, Ubuntu 12.04 and Mac OS X 10.6. Verified fixed.

Note You need to log in before you can comment on or make changes to this bug.