JPG attachments are corruptly saved when coming from IMAP-server

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: bert.verhees, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

I got an email with about thirty JPG's attachments attached, when I tried to
save them, everything worked as expected, but when I tried to open the saved
JPG's it occurred that they were no longer to recognize as JPG's by the viewer,
which was f.e. Windows Picture Preview, but also others.

Thunderbird showed the JPG's well embedded in the email.

I used another email programm to connect to the IMAP-server (Pegasus) and it
worked fine, this alos proved that the JPG's were not corruped inside the email.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
I am using Mozilla Thunderbird, version: version 0.8 (20040913)
did you save them all at once, or one at a time? Have you tried a more recent .8
nightly build?
I tried saving them all at once, I did not try the latest build, if you say,
that solved the problem, I will try it.
I'm not sure if the latest version solves the problem, but it's worth trying. Do
you have the folder containing the e-mail configured for offline use?
(In reply to comment #4) 
> I'm not sure if the latest version solves the problem, but it's worth 
trying. Do 
 
I will do sometime, when I have time 
 
> you have the folder containing the e-mail configured for offline use? 
 
No 
 
 
I have a similar problem though Thunderbird already shows only parts of the
picture: it stops somewhere in the middle. The preview, however, is visible in
the  folder with Thumbnails (Windows XP). 
I checked the email with pine/Linux, where I got not only the full picture but
additional four, which Thunderbird did not show at all.
This is a picture I got with Thunderbird, and it didn't change when I used
Firefox to watch it, neither when I saved it and used another viewer. When I
checked the emails with pine/Linux, I saw that I got five pictures altogether,
and none of them was corrupted.
I see this happening on my windows xp sp2 machine with thunderbird 1.06.  the
only time jpg's are fully visible is if the message containing them has been
moved to trash or to a local folder; also, if several jpg's have been attached,
the entire list of them now appears at the bottom of the message (once msg has
been moved).
also happens on my linux rh fc2 machine w/t-bird 1.06 as per my 1st comment.
HTML attachment is also corrupted with POPS instead of IMAP.

User client on both MAC and XP gets HTML gibberish instead of browser view, e.g.:
problem remains unfixed in t-bird 1.5.0.4 (20060615) running on linux 2.6.16-1.2096_FC4 and Windows XP SP2...
QA Contact: general
Seems fixed now, never experienced this bug for a long time
The problem still exists in 1.5.0.12 (20060911).

The first time I launch an attachment (.doc or .ppt) the attachment opens inside soffice without incident.  Subsequent attempts complain about an input/output error.

I was able to look at the .eml files and discovered the base-64 encoded attachment was prematurely abbreviated.  The trailing document separate no longer displayed in the "view message source" option.

The message remains in-tact on the Exchange server.  It is only corrupted inside Thunderbird.
this problem has gone away since we switched to a new mail system. it seems that in the old aix based system that we used, there was a segment limit size of 256k.
since cutover to the new system (mirapoint - linux based), no problem.
=> WFM per reporter comment 12.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
It shouldn't be resolved because the problem persists for other users--namely myself.  Mine is an IMAP connection to an Exchange server.  I can support the bug by showing how the messages are prematurely cut-off resulting in a corrupted file (see comment #13).

Please reopen.
(In reply to comment #16)
> It shouldn't be resolved because the problem persists for other users--namely
> myself.  Mine is an IMAP connection to an Exchange server.  I can support the
> bug by showing how the messages are prematurely cut-off resulting in a
> corrupted file (see comment #13).
> 
> Please reopen.

Reporter's issue is gone which by definition sets the bar for this bug, and indeed the majority of posters here. So the best course of action is to seek out a bug that better matches your issue, including a match on exchange. If not successful, then please file a new bug.  Also, your issue will receive better attention if you can say that the problem still exists on either version 2 or trunk build.
You need to log in before you can comment on or make changes to this bug.