Key bindings should be user configurable

RESOLVED DUPLICATE of bug 234963

Status

()

--
minor
RESOLVED DUPLICATE of bug 234963
14 years ago
14 years ago

People

(Reporter: z_a_n_e_y, Assigned: aaronlev)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; BTinternet V8.4; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

BACKSPACE to go back a page is causing usability problems on some pages when 
typing and it loses focus and then the page goes BACK.  I would like to be able 
to disable this and or configure the key bindings to my own taste.

Reproducible: Always
Steps to Reproduce:
1.  Go to a page
2.  Start typing and make the inputbox lose focus while typing
3.  Press backspace

Actual Results:  
Page goes back and information lost or have to reload slow page on slow 
connetion etc etc... annoyance

Expected Results:  
Nothing to happen when i press backspace
this sounds like something for an extension
(Reporter)

Comment 2

14 years ago
Why an extension when this is simply exposing what is already there?

%PROGRAMFILES%\Mozilla Firefox\res\builtin\platformHTMLBindings.xml  ??

    <key keycode="VK_BACK" command="cmd_handleBackspace"/> in browser.jar
browser.xul ???

If we make this configurable then everybody is happy.

I don't like the idea of "YET ANOTHER EXTENSION" for everything, by the time I
will be finished I will have more extensions than browser (YET ANOTHER MEDIA
PLAYER syndrome)

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 234963 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.