The default bug view has changed. See this FAQ.

Invalid path offered when file already exists (Save all attachments)

VERIFIED FIXED in mozilla1.9alpha1

Status

MailNews Core
Attachments
VERIFIED FIXED
13 years ago
9 years ago

People

(Reporter: Ivan Ičin, Assigned: Magnus Melin)

Tracking

({verified1.8.1.2})

Trunk
mozilla1.9alpha1
verified1.8.1.2

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Thunderbird version 0.8 (20040913)

I guess it is a mail/news bug, but as I use only Thunderbird, I submited it
here. I didn't find any doubled in MailNews bugs.

Reproducible: Always
Steps to Reproduce:
1. find message with attachments
2. save at least one attachment to dir
3. save all attacments to that dir
4. click cancel in dialogue (not to replace file)
Actual Results:  
Save file dialogue appeared with whole path in file name field begining with c-\
instead of c:\

Expected Results:  
There should be no path in file name field, or at least it should begin with c:\

This is probably MailNews issue, but I am using Thunderbird so I am reporting
here (I didn't find any duplicates in MailNews)

Comment 1

13 years ago
*** Bug 270384 has been marked as a duplicate of this bug. ***

Comment 2

13 years ago
Reproduced with TB 0.9+1112, and with Moz 1.8a5-1019.

Behavior occurs with MailNews, so updating Product.
Duplicate is from Mac OS X, so updating platform.
Assignee: mscott → sspitzer
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → Attachments
Ever confirmed: true
OS: Windows XP → All
Product: Thunderbird → MailNews
Hardware: PC → All
Version: unspecified → Trunk
Product: MailNews → Core

Comment 3

12 years ago
*** Bug 273183 has been marked as a duplicate of this bug. ***

Comment 4

12 years ago
*** Bug 287343 has been marked as a duplicate of this bug. ***

Comment 5

12 years ago
*** Bug 291978 has been marked as a duplicate of this bug. ***

Comment 6

12 years ago
*** Bug 222752 has been marked as a duplicate of this bug. ***

Comment 7

12 years ago
Created attachment 182467 [details] [diff] [review]
proposed patch

get leaf name before open filepicker.

Comment 8

12 years ago
Created attachment 182469 [details] [diff] [review]
proposed patch (removed all tabs)
Attachment #182467 - Attachment is obsolete: true

Comment 9

12 years ago
Comment on attachment 182469 [details] [diff] [review]
proposed patch (removed all tabs)

I want a reviewer to review this patch. But I don't know who are reviewers of
mailnews.

Updated

12 years ago
Attachment #182469 - Flags: review?(bienvenu)

Comment 10

12 years ago
*** Bug 315275 has been marked as a duplicate of this bug. ***

Comment 11

12 years ago
*** Bug 229233 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 12

11 years ago
*** Bug 322924 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 13

11 years ago
*** Bug 336567 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 14

11 years ago
*** Bug 348380 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 15

11 years ago
Created attachment 246627 [details] [diff] [review]
proposed fix based on the patch by Katsuhiro MIHARA

This is a slightly modified patch based on the earlier one by Katsuhiro MIHARA. (I don't know what the braces were supposed to do there... ?)
Assignee: sspitzer → mkmelin+mozilla
Attachment #182469 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #246627 - Flags: superreview?(bienvenu)
Attachment #246627 - Flags: review?(bienvenu)
Attachment #182469 - Flags: review?(bienvenu)

Comment 16

11 years ago
Comment on attachment 246627 [details] [diff] [review]
proposed fix based on the patch by Katsuhiro MIHARA

this fixes the problem; thx for the patch. My one worry is the error returns, which will prevent the UI from coming up (note that we handle the other errors w/o returning). But I don't think we should encounter these errors...
Attachment #246627 - Flags: superreview?(bienvenu)
Attachment #246627 - Flags: superreview+
Attachment #246627 - Flags: review?(bienvenu)
Attachment #246627 - Flags: review+
(Assignee)

Updated

11 years ago
Whiteboard: [checkin needed]
mozilla/mailnews/base/src/nsMessenger.cpp 	1.349
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → mozilla1.9alpha
(Assignee)

Updated

10 years ago
Attachment #246627 - Flags: approval-thunderbird2?

Updated

10 years ago
Attachment #246627 - Flags: approval-thunderbird2? → approval-thunderbird2+
(Assignee)

Updated

10 years ago
Whiteboard: [checkin needed (1.8 branch)]
mozilla/mailnews/base/src/nsMessenger.cpp 	1.320.2.16
Keywords: fixed1.8.1.2
Whiteboard: [checkin needed (1.8 branch)]
Verified fixed for branch/1.8.1.2 with Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.2pre) Gecko/20070124 Thunderbird/2.0b2pre Mnenhy/0.7.4.10002 ID:2007012504
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.1.2 → verified1.8.1.2

Updated

10 years ago
Duplicate of this bug: 368956
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.