Draft messages should never be marked read

RESOLVED WONTFIX

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED WONTFIX
14 years ago
5 years ago

People

(Reporter: Jamie Nettles, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [driver: WONTFIX?])

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10 StumbleUpon/1.998
Build Identifier: Thunderbird version 0.8 (20040913)

Marking a draft message as read removes the indication on the folder that tells
you you have unfinished drafts.  Since drafts originate with you, the concept of
read/unread really doesn't apply - you can't create a draft message without
reading it.  Draft messages should always be marked as "unread" until sent.  The
current behavior is technically "correct" but the proposed behavior is more
intuitive and useful.

Reproducible: Always
Steps to Reproduce:
1. Create a message.
2. Save it as a draft.
3. Click on the message to view it in the preview pane.

Actual Results:  
The draft message is marked as read and the draft folder does not include that
message in its count of unread messages.

Expected Results:  
The draft message should still be marked as "unread" and the draft folder should
still include that message in its count of "unread" messages.

Comment 1

13 years ago
while part of me agrees with the reporter's logic, i would like to see this bug
closed not-to-be-fixed, because i like to use the "unread/read" marker as sort
of a "still-to-be-sent/decided-probably-to-never-send" marker.  this way, in my
left pane, it will show drafts in bold and a number in parenthesis if i've saved
drafts that i haven't decided not to send, but will show a whole count of drafts
i've started but never sent.  (the use case of a packrat, i guess ...)

Comment 2

12 years ago
I think this bug goes in the wrong direction, and I agree with johndoe that it should be closed as "wontfix". Also, I think defaulting to "read" makes sense as a draft has always been "read." It is not "new" mail or new information waiting to be read. The bug submitter is basically using read/unread as the "to do" label. So, I would suggest he/she might search for or start a bug on marking drafts with "to do" instead of "unread."

Comment 3

12 years ago
Summary: 
I completely disagree with the premise of this bug report, and in the implied observed behaviour.
_____
Body:
The current behaviour (for me) in version 1.5 (20051201) is that they are marked unread. This I find annoying since the bold and the (unread number) by the side draw my eye before I realise the unread is not in my inbox. This is inconsiatant with the behaviour of the 'sent' folder. If something is in either 'drafts' or 'sent', I must have read it.

Perhaps we could have an option in preferances to keep us all happy?
QA Contact: front-end

Updated

10 years ago
Assignee: mscott → nobody
I agree to comment #2, comment #3: this bug should be closed as INVALID from driver.
Whiteboard: [driver: WONTFIX?]

Comment 5

9 years ago
->WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX

Comment 6

5 years ago
We should be able to set the parameter of the delay before auto-mark as read individually for each folder, or at least for Drafts folder.
You need to log in before you can comment on or make changes to this bug.