some themes not updated even though newer version exists

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
7 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

1.7 Branch
x86
Linux
Points:
---
Bug Flags:
blocking-aviary1.0 -
blocking-aviary1.5 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
spun off from bug 257179, which is labeled as fixed on aviary1.0. tested with
2004101209-0.9+ on linux fc2.

I noticed that sometimes newer versions of themes are not being detected. For
example, Phoenity:

https://update.mozilla.org/themes/moreinfo.php?id=5&vid=824

Phoenity v1.3 and v1.3.1 are both 0.10+ compatible (see
https://update.mozilla.org/themes/moreinfo.php?id=5&vid=824&page=releases)

1. install the theme Phoenity v1.3.

2. after installation is done, select Phoenity in the Theme manager and hit Update.

3. the Update wizard appears and says that there was a problem with the
download, and the newer 1.3.1 version is not found.

note that it doesn't matter if I enable this theme then quit and restart.

screenshot of error in update wizard: see attachment 161908 [details].
(Reporter)

Comment 1

14 years ago
not all themes exhibit this. for example, SphereGnome 0.9.7.4 (but watch out for
bug 264088) and  708090 v1.47 do find the newer versions.

carrying over a question to Marcia from bug 257179 comment 9: when you tested
Curacao, did you get the same error seen in attachment 161908 [details]?
(Reporter)

Comment 2

14 years ago
would this be a problem with firefox's updating mechanism, or an issue with the
3rd party theme itself?
(Reporter)

Comment 3

14 years ago
to answer my own question about Curacao on Mac: the result is different, in that
the Update Wizard just says "No updates were found" (no error details either).
Sarah: When testing your bug, I also came across other instances where I
installed an older theme and when I tried update it did not find a new instance
of the theme despite the fact that one existed. I can play around with this some
more and give other examples if need be.
(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0? → blocking-aviary1.0-

Comment 5

14 years ago
Some of it may depend on the actual versioning scheme.  If it sorts by version,
then 0.9 will probably appear greater than 0.13.  
(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.1?
Flags: blocking-aviary1.1? → blocking-aviary1.1+

Updated

14 years ago
Flags: blocking-aviary1.1+ → blocking-aviary1.1-
Is anyone still seeing this with 1.5?
Assignee: bugs → nobody
QA Contact: bugs → extension.manager
Resolving WFM
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.