icon for "click to sort by junk status" fails after using "Run Junk Mail Controls on Folder"

RESOLVED DUPLICATE of bug 181143

Status

RESOLVED DUPLICATE of bug 181143
14 years ago
14 years ago

People

(Reporter: gene, Assigned: sspitzer)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040927
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040927

I am working offline.  I have about 3,000 messages in 
Inbox.  I manually toggle the junk status to label about
10 messages as junk.  I then click on "junk icon" at top
of pane containing messages of Inbox.  This is the icon
with the text, "Click to sort by junk status".
The junk messages are
sorted to top or bottom as they should be.

I then select the menu:  Tools > Run Junk Mail Controls on
Folder.  (I had enabled Junk Mail Controls.)  After this,
about 30 more messages are flagged as "Junk" by Mozilla.

I then click again on the junk status icon.  This time,
the ordering of the messages does not change.  The newly
found junk mail from the menu command stays in its original
position and does not move to the top with the other junk mail.

For other details, I had selected that Junk mail should be
moved to the junk folder of local folder.  
However, I also observed the same phenomenon prior to my making
this selection.

Reproducible: Always
Steps to Reproduce:
1.  Label 10 messages at random as junk.
2.  Then select "sort by junk status" icon.
3.  Select menu:  Tools > Run junk mail controls on folder.
4.  Verify by scrolling that some other messages are also now flagged as junk.
5.  Select "sort by junk status" icon, again.

Actual Results:  
The newly flagged junk messages do not move to the top.

Expected Results:  
It should move them to the top with the others.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 181143 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.