Cannot launch/open attachment after move/update of application because OK button remains disabled

RESOLVED FIXED

Status

defect
--
minor
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: super.gnu, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: version 0.8 (20041015)

Once an application for a specific kind of attachment has been selected -
without "do this automatically for files like this from now on" - and the
application or its installation directory is moved/deleted, the OK button in the
"Open" (launch application) dialog gets disabled and remains disabled even when
you select "save to disk" or any other application in this dialog.

I've detected this bug after an switch of an application. Because the directory
has changed and the old installation had been removed before, I was able to
observe the described behavior.

Reproducible: Always
Steps to Reproduce:
0. Prepare a mail with an attachment of a filetype, which can be opened with at
least one non-default application (e.g. notepad and a "real" text editor). Make
sure that automatic launch/open for this filetype does not exist -- if
appropriate, delete an existing default application for this filetype in the
settings/attachment dialog.

1. Select the mail with an attachment
2 [review]. Context menu on the attachment --> "Open"
3. Select an application (I have selected a non-system-default application, e.g.
a simple viewer instead of the full word processor) in the "open with" list
4. Don't select "do this automatically for files like this from now on"! OK.
5. Close attachment/launched application, close thundbird
6. Move or delete the application (imagine that this happens after an update -
or when the user switches from an inferior commercial product to a new, better
and over-the-top open source application)
7. Open thunderbird, select attachment again and click "open" in the context menu
Actual Results:  
OK button is disabled and stays disabled, you can select whatever you want
(default application, new application or save to disk). That's not nice (IMHO a
bug), because there's no (non-hacking) way to launch any application for this
kind of file again. Note that the settings dialog for attachments does not help
here, because there are only file types listed which are launched automatically.

Note: Save to disk from the context menu still works.

Expected Results:  
Of course I do not assume that Thunderbird can open the attachment with the
original (moved or deleted) application, but the current implementation makes it
impossible to switch to a new (or to the moved) application, because "OK" is
disabled. For a non-technical users (profile-hacking is not user friendly) it
gets impossible to launch any application for this type of file again (that's
possibly very annoying, especially for an average user).

Workaround/solution: Hack the mimeTypes.rdf file in your profile directory:
Either update the path/application filename if moved -- or remove the according
RDF:Description entry. The "OK" button gets available again.

Of course you can also hack the mimeTypes.rdf to exposure the bug: Changing the
path or the name of an application (which is NOT launched automatically) will
also result in a disabled OK button until you restore the original path. I think
that's easier for testing, you don't have to move around applications to test if
the bug is still there.

The bug does NOT occur in Mail/News component of the latest Mozilla build
(1.8.0.2004101505).
Bug still exists in Thunderbird 0.9 (20041103).

Please would somebody confirm this bug here? Because the bug has already been
confirmed in the Thunderbird forum, thread
http://forums.mozillazine.org/viewtopic.php?t=143004. Thanks.
Does anyone think that this is related to this bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=264492

?

Yes. I've verified it: The same bug exists in *Firefox* 1.0 [Mozilla/5.0
(Windows; U; Windows NT 5.0; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0].

You can follow the same procedure in Firefox and you get the same "misbehaviour"
- a disabled "OK" button. As for Thunderbird an important pre-condition is that
you don't use automatic actions ["do this automatically for files like this from
now" on has never been selected] - neither save nor open).

I'm with Andrew - I looks like this Thunderbird 0.9 bug and Firefox bug #264492
are very closely related.
The bug still exists in Thunderbird 1.0RC. 

By the way: Has anyone appropriate rights to confirm this bug?
OS: Windows 2000 → All
And in Thunderbird 1.0
Component: Mail Window Front End → General
In Bug #279735 a user reports this seemt to be fixed in TB 1.0.1RC
(In reply to comment #6)
> In Bug #279735 a user reports this seemt to be fixed in TB 1.0.1RC

I've tested nightly build thunderbird-2005-03-17-07-aviary1.0.1 [identifies as
version 1.0.2 (20050317) - huh?].

Yes. Looks good. I've closed this bug. Lets hope there is no regression problem
in the official release 1.0.1...
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.