Tab spacing issues (space missing between varied tabs)

RESOLVED DUPLICATE of bug 175656

Status

()

Firefox
Tabbed Browser
--
trivial
RESOLVED DUPLICATE of bug 175656
13 years ago
13 years ago

People

(Reporter: u88484, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows XP
Points:
---
Bug Flags:
blocking-aviary1.5 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
When 5 tabs are open in the tab bar, there is no spacing between the 2nd and 3rd
tab when 5 tabs are opend and the 1st, 4th or 5th tab is active. Not present
when only 4 tabs open and also not present when 6 tabs or more are opend...only
when 5 tabs are opend.
(Reporter)

Comment 1

13 years ago
Created attachment 162652 [details]
screenshot
(Reporter)

Comment 2

13 years ago
changing Severity to trivial...perhaps a blocker since its a GUI bug
Severity: critical → trivial
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041019 Firefox/1.0

Confirming

the position of the gap/n-gap varies

repro:
1.open non-maximised window with multiple tabs
2.slowly decrease window width
3.notice the spaces constantly vary (bad calculation ?)

Comment 4

13 years ago
For me its between the 3rd and 4th tab when 2nd or 5th is active.

Your bug (no spacing between the 2nd and 3rd tab when  1st, 4th or 5th tab is
active) does not occur

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041025
Firefox/1.0 (Win2k SP4)
(Reporter)

Comment 5

13 years ago
wanted to add that this is with resolution set at 1280*1024
(Reporter)

Updated

13 years ago
Flags: blocking-aviary1.1?
Flags: blocking-aviary1.1? → blocking-aviary1.1-

Comment 6

13 years ago
Created attachment 177232 [details]
Spacing Bug Between 3rd and 4th tabs

Here the spacing bug is in a current beast build of Firefox.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050312
Firefox/1.0+

As you can see looking at the 3rd tab (active tab). There is no space at all;
in fact it seems to be have been absorbed into the other tab.

This bug does not appear to show up in other Themes depending on how they make
their tabs.

Comment 7

13 years ago
(In reply to comment #5)
> wanted to add that this is with resolution set at 1280*1024

I'm seeing similar on here at 1024*768

Not the same tabs, though. I never noticed this until now, I have ten tabs open
and the space between 4 and 5 is missing. With 9 tabs open, every second space
is missing.

Comment 8

13 years ago
(In reply to comment #7)
> I'm seeing similar on here at 1024*768
> 
> Not the same tabs, though. I never noticed this until now, I have ten tabs open
> and the space between 4 and 5 is missing. With 9 tabs open, every second space
> is missing.

No, actually, I was wrong, I am also on 1280*1024. Sorry.

Comment 9

13 years ago
I see it when maximized at 1024x768. I'm sure this rounding imprecision shows up
at a variety of maximized resolutions.

With any number of tabs >= 3, resizing the window horizontally reveals at least
one of these tab gaps changing size (you may have to focus different tabs to
notice every gap problem). The gap between the first and second tabs seems to
always remain perfect. Definitely a trivial UI glitch.

This is present in the trunk, not just the 1.0 branch. Summary should probably
be changed to something more all-encompassing like "Tab spacing issues." I'll
leave those changes to the reporter or owner.
(Reporter)

Updated

13 years ago
Summary: Space missing between 2nd and 3rd tab when 5 tabs opend → Tab spacing issues (space missing between varied tabs)
Version: 1.0 Branch → Trunk

Comment 10

13 years ago
Correct me if I'm wrong, but if the UI (including the tab bar) is drawn by Gecko
then surely this is a rounding error in Gecko's rendering rather than Firefox
itself?

I say this because I've noticed a couple of rounding errors when designing sites
- e.g. where font sizes cause containing boxes to have sizes that aren't whole
pixels - this error looks similar in behaviour. I'll make an example in html and
attach it.

Comment 11

13 years ago
Created attachment 177348 [details]
rounding bug demonstration

You might need to resize the text to see the bug.

Comment 12

13 years ago
So this might be a dupe of Bug 176237.
(In reply to comment #11)
> Created an attachment (id=177348) [edit]
> rounding bug demonstration
> 
> You might need to resize the text to see the bug.

Yes. I can confirm this here.

Using Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.7.6) Gecko/20050306 Firefox/1.0.1

*** This bug has been marked as a duplicate of 175656 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.