Note: There are a few cases of duplicates in user autocompletion which are being worked on.

flash loses ability to play sound if other sound is playing

RESOLVED INVALID

Status

()

Core
Plug-ins
RESOLVED INVALID
13 years ago
7 years ago

People

(Reporter: Jamie Zawinski, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
If an audio-using Flash plugin is started while some other sound is already
playing on the sytem, then Flash loses the ability to play sound forevermore,
until one quits and restarts Mozilla.  Flash animations play fine, and Mozilla
is otherwise functional; but Flash can't ever make sound again.

I imagine that this is somehow related to the former bug 58339.

I also imagine that this is a bug in the Flash plugin and not Mozilla per se.

However, Mozilla could make this suck less by giving us some way to reset things
short of quitting and restarting.  If there was some way to "unload" the Flash
plugin, so that the Flash code could get a clean slate without having to lose
all of my windows and history state, that would be nice.

You'd think that closing the (only) window with a Flash plugin on it would reset
things, but apparently not.  Plugins never get unloaded or reset, I guess?

Mozilla 1.7.3
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922
Fedora Core 2
Linux 2.6.8-1.521smp #1 SMP Mon Aug 16 09:25:06 EDT 2004 i686 athlon i386
AMD-768 Opus Audio, snd-intel8x0
(Reporter)

Comment 1

13 years ago
I should have mentioned:

    File name: libflashplayer.so
    Shockwave Flash 7.0 r25

Comment 2

13 years ago
*** Bug 265063 has been marked as a duplicate of this bug. ***
*** Bug 273490 has been marked as a duplicate of this bug. ***
Per dup, Flash also loses its voice if you play Flash with audio, close that
page, play audio with another program, then try to play another bit of Flash
with audio.
*** Bug 280976 has been marked as a duplicate of this bug. ***

Comment 6

12 years ago
*** Bug 300954 has been marked as a duplicate of this bug. ***

Comment 7

10 years ago
I just tested this based on an email received today. While playing a song through Amarok (1.4) I loaded firefox 2.0.0.3 and played a video through YouTube (flash 9.x) and had no issues with sound from either. Both streams played.  I'm on SUSE 10.1, KDE 3.5.6, kernel 2.6.16.27-0.9-default i686.

Comment 8

10 years ago
works for me too. i had this issue with flash 7, but it's resolved with flash 9.
thanks for updating the bug. and reporter "I don't use desktop Linux any more".

strictly speaking the bug is invalid because the is flash player - as noted in bug 300954 - since the problem is gone, closing bug as invalid.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Comment 10

7 years ago
It seems this bug appears again in latest Shockwave Flash 10.1 r85 in my Ubuntu 10.10.
I found that the Flash plugin will lock the audio device, other applications are not able to play audio if Firefox played flash before.After I close Firefox, everything now works.
You need to log in before you can comment on or make changes to this bug.