Closed Bug 26527 Opened 20 years ago Closed 18 years ago

When displaying errors from mailservers the text has [] (square) in it

Categories

(MailNews Core :: Backend, defect, P3)

x86
Windows 98
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: bugzilla, Assigned: naving)

References

Details

Attachments

(1 file)

This error I'm not able to recreate all the times but sometimes I'm getting this 
funny error message. Please remove the [] (square) at the end of the message!
Attached image Error with square in it
Reassign to jefft. Looking at the screen shot, maybe we're not stripping some
trailing CRLF?
Assignee: phil → jefft
Status: NEW → ASSIGNED
Target Milestone: M15
Mass moving to M16 to get these off the M15 radar.  Please let me know if this
is really an M15 stopper.
Target Milestone: M15 → M16
Not beta2 stopper, marking M18.  Please add beta2 keyword if you disagree.
Target Milestone: M16 → M18
Could be a buffer overrun/corruption. 
Please think of that as a possibility. 
We have seen similar problem happen elsewhere
and I think jfrancis might have worked on it.
This character shows up as a muscial 1/8th note
depending on what fonts you have on your system.
*** Bug 42407 has been marked as a duplicate of this bug. ***
In the other bug, mscott says that we are not
stripping off CRLF -- not a buffer overrun problem.
QA Contact: lchiang → huang
When you get somekind of error back from the mail server, the error text always 
include a [] (square) in the end of the text. CRLF should be stripped of any 
error text back from the mail server when displaying it.
Summary: Reading mail gives my error with [] (square) in it → When displaying errors from mailservers the text has [] (square) in it
Could someone point me to the code where displaing of error occors, since this 
bug is kind of bugging me, and it must be an easy fix.
Jeff is in sabbatical. Ccing bienvenu & mscott who should know....
I already have a bug for this. We aren't stripping the CRLFs of the server text
before throwing the dialog. 
*** Bug 49504 has been marked as a duplicate of this bug. ***
reassigning jefft's bugs to naving
Assignee: jefft → naving
Status: ASSIGNED → NEW
Target Milestone: M18 → ---
I think the baby is fixed. has anybody seen any squares lately...?
I haven't seen this recently.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → WORKSFORME
haven't seen these either lately...
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.